diff mbox series

[bug#53717] gnu: Add rofi-wayland.

Message ID 87czjadpsp.fsf@trop.in
State New
Headers show
Series [bug#53717] gnu: Add rofi-wayland. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Feb. 26, 2022, 7:56 a.m. UTC
On 2022-02-10 17:20, Xinglu Chen wrote:

> Andrew schrieb am Dienstag der 01. Februar 2022 um 11:40 +03:
>
>> Tested on sway session.
>>
>> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.
>> ---
>>  gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
>>  1 file changed, 35 insertions(+)
>>
>> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
>> index ec995c3496..c2bd1d1d5c 100644
>> --- a/gnu/packages/xdisorg.scm
>> +++ b/gnu/packages/xdisorg.scm
>> @@ -53,6 +53,7 @@
>>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>>  ;;; Copyright © 2021 jgart <jgart@dismail.de>
>>  ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
>> +;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -1742,6 +1743,40 @@ (define-public rofi
>>  by name.")
>>      (license license:expat)))
>>  
>> +(define-public rofi-wayland
>> +  (package
>> +   (inherit rofi)
>> +   (name "rofi-wayland")
>> +   (version "1.7.2+wayland1")
>
> We usually strip away prefixes and suffixes.  FWIW, version 1.7.3 seems
> to be available as well.

AFAIU, it's a part of a version, it can potentially be +wayland2,
+wayland3 if it will be necessary to make another intermediate release,
which is related to wayland/wlroots changes, while upstream version
still the same (1.7.3 for example).

>> +   (source (origin
>> +            (method url-fetch)
>> +            (uri (string-append "https://github.com/lbonn/rofi"
>> +                                "/releases/download/"
>> +                                version "/rofi-" version ".tar.xz"))
>> +            (sha256
>> +             (base32
>> +              "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
>> +   (build-system meson-build-system)
>> +   (arguments
>> +    (substitute-keyword-arguments (package-arguments rofi)
>> +      ((#:configure-flags flags '())
>> +       #~(list "-Dxcb=disabled"))))
>> +    (inputs
>> +     (list cairo
>> +           glib
>> +           libjpeg-turbo
>> +           librsvg
>> +           libxkbcommon
>> +           wayland
>> +           wayland-protocols
>> +           pango
>> +           startup-notification))
>> +    (description "Rofi is a minimalist application launcher.  It memorizes which
>> +applications you regularly use and also allows you to search for an application
>> +by name.
>> +
>> +This is a fork with added support for Wayland via layer shell protocol.")))
>
> The home-page should also be changed to point to the fork.
>
> Otherwise, LGTM!

Thank you for the pointing out, updated version, home-page.
diff mbox series

Patch

From f470b6f6a6b4ec1ef789a302af3ee98d562462d8 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Tue, 1 Feb 2022 11:40:08 +0300
Subject: [PATCH] gnu: Add rofi-wayland.

Tested on sway session.

* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
 gnu/packages/xdisorg.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 42452d0721..c43a5fbd44 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1743,6 +1744,41 @@  (define-public rofi
 by name.")
     (license license:expat)))
 
+(define-public rofi-wayland
+  (package
+   (inherit rofi)
+   (name "rofi-wayland")
+   (version "1.7.3+wayland1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "https://github.com/lbonn/rofi"
+                                "/releases/download/"
+                                version "/rofi-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1gfs13zfqg9f4prx8yylxvv93yr6j74nmhlm3wabr6jljbbr7jc8"))))
+   (build-system meson-build-system)
+   (arguments
+    (substitute-keyword-arguments (package-arguments rofi)
+      ((#:configure-flags flags '())
+       #~(list "-Dxcb=disabled"))))
+    (inputs
+     (list cairo
+           glib
+           libjpeg-turbo
+           librsvg
+           libxkbcommon
+           wayland
+           wayland-protocols
+           pango
+           startup-notification))
+    (home-page "https://github.com/lbonn/rofi")
+    (description "Rofi is a minimalist application launcher.  It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
 (define-public rofi-calc
   (package
     (name "rofi-calc")
-- 
2.34.0