diff mbox series

[bug#55381,05/14] gnu: Add r-unglue.

Message ID 87czge67sd.fsf@posteo.net
State New
Headers show
Series None | expand

Commit Message

kyle May 15, 2022, 4:38 p.m. UTC
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> kyle schreef op do 12-05-2022 om 02:10 [+0000]:
>> Use syntax inspired by the package 'glue'
>
> Shouldn't this be 'r-glue'?  Guix doesn't have a package named 'glue'.
> Also, writing a description (+- = some factual statements) in the
> imperative mood ... is technically possible, but I wouldn't recommend
> it.  Referring to another package for more information on what 'rust-
> unglue' is about is technically possible, but a bit cumbersome for the
> reader I think.  Maybe you can re-use parts of the description of
> 'r-glue'.
>

This (and r-glue too) is an R package designed to be installed and used
from within R. I noticed that the Pandas python package, for example,
doesn't refer to itself as python-pandas in its Guix documentation.
There are numerous other instances in Guix where such library software
for high-level languages refer to themselves and other related packages
as within their own ecosystems instead of the Guix ecosystem. However,
in this particular case I included in parenthesis "(provided by r-glue
in Guix)".

>>  to extract matched substrings in a
>> +more intuitive and compact way than by using standard regular expressions.
>
> This is a bit markety language.
>
> More generally, upstream descriptions often aren't great and require
> some tweaking, expanding (and sometimes abbreviation, though not in
> this particular case).  The manual has some general guidelines in
> (guix)Synopses and Descriptions.

Thanks, I had a look.

> FWIW, I consider 'emacs', 'hello' and 'sed' to have good descriptions,
> though the emacs description goes a bit markety with ‘highly
> customizable ... extensive documention on everything’ and such ...
> though in the case of Emacs those claims appear to be actually true so
> maybe it's a good description after all.
>

I made a few small tweaks which I feel significantly reduces the
"marketing" aspect. See the included patch.
Cheers,
Kyle
diff mbox series

Patch

From 9a30410e850000e839002649a5f6183f174fdfa2 Mon Sep 17 00:00:00 2001
Message-Id: <9a30410e850000e839002649a5f6183f174fdfa2.1652634138.git.kyle@posteo.net>
From: Kyle Andrews <kyle@posteo.net>
Date: Sun, 15 May 2022 13:01:30 -0400
Subject: [PATCH] gnu: Add r-unglue.

---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c05f20ea7..bbe18e1d67 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33255,3 +33255,23 @@  (define-public r-zoeppritz
 coefficients or scattering amplitudes, for seismological P and S-waves at an
 interface.")
     (license license:gpl2+)))
+
+(define-public r-unglue
+  (package
+   (name "r-unglue")
+   (version "0.1.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "unglue" version))
+     (sha256
+      (base32 "0w8ld4xllx0lj1jz8i2sj92f8136hlwri1d8ldpg1ymxj7aw93vg"))))
+   (properties `((upstream-name . "unglue")))
+   (build-system r-build-system)
+   (home-page "https://cran.r-project.org/package=unglue")
+   (synopsis "Extract Matched Substrings Using a Pattern")
+   (description
+    "Use syntax inspired by the package 'glue' (provided by r-glue in
+Guix) to extract matched substrings in a more compact way than by
+using regular expressions.")
+   (license license:gpl3)))
-- 
2.36.0