diff mbox

[bug#57806,0/2] Add cl-njson and cl-nactivitypub.

Message ID 87czbyuj67.fsf@aartaka.me
State Accepted
Headers show

Commit Message

Artyom Bologov Sept. 14, 2022, 2:23 p.m. UTC
Hello,

This adds cl-nactivitypub and it's dependency cl-njson.

Artyom Bologov (2):
  gnu: Add cl-njson.
  gnu: Add cl-nactivitypub.

 gnu/packages/lisp-xyz.scm | 100 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 100 insertions(+)

Comments

Guillaume Le Vaillant Sept. 15, 2022, 8:41 a.m. UTC | #1
Patches pushed as 170a3962404a9c0499c065d1c3fd9532f56e17b8 and
following.
Thanks.
diff mbox

Patch

From 98554a68ccace9feb3bccdba36ab31d388b77fae Mon Sep 17 00:00:00 2001
From: aartaka <aartaka@protonmail.com>
Date: Wed, 14 Sep 2022 18:07:07 +0400
Subject: [PATCH 2/2] gnu: Add cl-nactivitypub.

* gnu/packages/lisp-xyz.scm (cl-nactivitypub, ecl-nactivitypub,
  sbcl-nactivitypub): New variables.
---
 gnu/packages/lisp-xyz.scm | 49 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a109d7a15d..acb9839e06 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22083,6 +22083,55 @@  (define-public cl-njson
 (define-public ecl-njson
   (sbcl-package->ecl-package sbcl-njson))
 
+(define-public sbcl-nactivitypub
+  (package
+    (name "sbcl-nactivitypub")
+    (version "0.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/atlas-engineer/nactivitypub")
+                    (commit version)))
+              (file-name (git-file-name "cl-nactivitypub" version))
+              (sha256
+               (base32
+                "07n8a9cfzc96kwsb6z4v5ns09ad2qyq45bjb779azcs7ds144a6r"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs (list sbcl-njson
+                  sbcl-serapeum
+                  sbcl-cl-str
+                  sbcl-local-time
+                  sbcl-lparallel
+                  sbcl-dexador
+                  sbcl-quri))
+    (home-page "https://github.com/atlas-engineer/nactivitypub")
+    (synopsis
+     "Common Lisp Implementation of ActivityPub and ActivityStreams standards.")
+    (description
+     "Features:
+@itemize
+
+@item Parsing and un-parsing ActivityStreams JSON-LD objects to/from CLOS
+objects with convenient accessors on those.
+
+@item Sending and fetching ActivityStreams objects to/from the
+ActivityStreams-enabled HTTP(S) URLs.
+
+@item Semantic info extraction with methods like @code{name*}, @code{url*},
+@code{author*}, and @code{published*}.
+
+@item No reliance on JSON parser. @code{njson} is used for parser-independent
+JSON handling. Load the parser backend you prefer!
+
+@end itemize")
+    (license license:bsd-3)))
+
+(define-public cl-nactivitypub
+  (sbcl-package->cl-source-package sbcl-nactivitypub))
+
+(define-public ecl-nactivitypub
+  (sbcl-package->ecl-package sbcl-nactivitypub))
+
 (define-public sbcl-utils-kt
   (let ((commit "4adfe2889036ab5ffdd3cc2182ca2cc692bf11ff"))
     (package
-- 
2.37.3