diff mbox series

bug#60444: [PATCH] gnu: Add guile-scheme-json-rpc

Message ID 87cz7mof32.fsf@gnu.org
State New
Headers show
Series bug#60444: [PATCH] gnu: Add guile-scheme-json-rpc | expand

Commit Message

Ludovic Courtès Jan. 10, 2023, 10:32 a.m. UTC
Hi,

Abhishek Cherath <abhi@quic.us> skribis:

> * gnu/packages/guile-xyz.scm (guile-scheme-json-rpc): New variable.

Applied with the cosmetic changes below: keeping a more conventional
order for fields, and improving the description as per
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9866b60b16..3f84594014 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1027,6 +1027,15 @@  (define-public guile-scheme-json-rpc
     (package
       (name "guile-scheme-json-rpc")
       (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
       (build-system gnu-build-system)
       (arguments
        `(#:phases (modify-phases %standard-phases
@@ -1035,21 +1044,13 @@  (define-public guile-scheme-json-rpc
                         (chdir "guile"))))))
       (inputs (list guile-3.0 guile-json-3))
       (native-inputs (list pkg-config))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
-      (synopsis "Library providing json-rpc capability in scheme")
+      (synopsis "Library providing JSON-RPC capability in Scheme")
       (description
-       "Experimental implementation of https://www.jsonrpc.org/specification,
-allows for calling methods on remote servers by exchanging json objects.")
-      (license license:expat)
-      (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/"))))
+       "This library implements parts of the
+@uref{https://www.jsonrpc.org/specification,JSON-RPC specification}, allowing
+for calling methods on remote servers by exchanging JSON objects.")
+      (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
+      (license license:expat))))
 
 (define-public guile-squee
   (let ((commit "a151fd006fa819945ca1d4749b173854269b9f70")