diff mbox series

[bug#68391,1/3] gnu: Add python-typeguard-4.

Message ID 87cyu7tuq6.fsf@troyfigiel.com
State New
Headers show
Series Add python-pandera | expand

Commit Message

Troy Figiel Jan. 11, 2024, 8:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-typeguard-4): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46a5e81cb4..d7bbdbdb13 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24804,6 +24804,24 @@  (define-public python-typeguard
 with PEP 484 argument (and return) type annotations.")
     (license license:expat)))
 
+(define-public python-typeguard-4
+  (package
+    (inherit python-typeguard)
+    (name "python-typeguard")
+    ;; This is the latest version we can use, becaue python-typeguard >= 4.0.1
+    ;; requires python-typing-extensions >= 4.7.0.
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "typeguard" version))
+       (sha256
+        (base32 "11yrc7pv2fajmicwiyc92sb5gphlw3zbxww8f2prrsh6rgdv6kqr"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '())
+    (propagated-inputs (list python-typing-extensions))))
+
 (define-public bpython
   (package
     (name "bpython")