diff mbox series

[bug#68631,v3] gnu: Add python-sphinx-issues.

Message ID 87cytpggzu.fsf@troyfigiel.com
State New
Headers show
Series [bug#68631,v3] gnu: Add python-sphinx-issues. | expand

Commit Message

Troy Figiel Jan. 21, 2024, 10:11 a.m. UTC
* gnu/packages/sphinx.scm (python-sphinx-issues): New variable.
---
 gnu/packages/sphinx.scm | 43 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)


base-commit: 9b657bab84be02935d66483da1ebbe4bc78c52fb
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7e5a929241..e280c06f2b 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -372,6 +373,48 @@  (define-public python-sphinxcontrib-newsfeed
     (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
     (license license:bsd-2)))
 
+(define-public python-sphinx-issues
+  (package
+    (name "python-sphinx-issues")
+    (version "4.0.0")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sloria/sphinx-issues")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0q4as8gibvin0n6h5y1q4cwz3b1nwgs0idfc94dbndx42pjiz1vn"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'patch-sphinx-build-path
+                     (lambda _
+                       ;; The path to the sphinx-build binary is hardcoded to
+                       ;; be in the same directory as the python
+                       ;; executable. That does not work when building the
+                       ;; package.
+                       (substitute* "tests/test_sphinx_issues.py"
+                         (((string-append "Path\\(sys\\.executable\\)"
+                                          "\\.parent\\.joinpath\\"
+                                          "(\"sphinx-build\"\\)"))
+                          (string-append "\""
+                                         #$(this-package-native-input
+                                            "python-sphinx")
+                                         "/bin/sphinx-build\""))))))))
+    (native-inputs (list python-flit-core python-pytest python-sphinx))
+    (home-page "https://github.com/sloria/sphinx-issues")
+    (synopsis "Sphinx extension for linking to a project's issue tracker")
+    (description
+     "This package provides a Sphinx extension for linking to a project's
+issue tracker.  This includes roles for linking to issues, pull requests and
+user profiles.  Support for GitHub is built-in, but other services can also be
+supported with @code{sphinx-issues}.")
+    (license license:expat)))
+
 (define-public python-sphinx-panels
   (package
     (name "python-sphinx-panels")