diff mbox series

[bug#69351] gnu: Add go-github-com-ugorji-go-codec.

Message ID 87cysm9oz9.fsf@troyfigiel.com
State New
Headers show
Series [bug#69351] gnu: Add go-github-com-ugorji-go-codec. | expand

Commit Message

Troy Figiel Feb. 24, 2024, 9:40 a.m. UTC
* gnu/packages/golang-web.scm (go-github-com-ugorji-go-codec): New variable.
---
 gnu/packages/golang-web.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5

Comments

Sharlatan Hellseher March 7, 2024, midnight UTC | #1
Pushed as a28498d83d644d02a0e02ce74954c6e936ff0543 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4f2c6f8c1a..5f5278e11c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1394,6 +1394,38 @@  (define-public go-github-com-tv42-httpunix
 sockets.")
       (license license:expat))))
 
+(define-public go-github-com-ugorji-go-codec
+  (package
+    (name "go-github-com-ugorji-go-codec")
+    (version "1.2.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ugorji/go")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11j0sd7kli2bh2npfr2znnvdjsk118rs8khqzfdp6pb5jm0l20ib"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/ugorji/go/codec"
+      #:unpack-path "github.com/ugorji/go"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-benchmarks
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively (string-append "src/"
+                                                               import-path
+                                                               "/bench")))))))
+    (propagated-inputs (list go-golang-org-x-tools))
+    (home-page "https://github.com/ugorji/go")
+    (synopsis "Codec and encoding library for various serialization formats")
+    (description
+     "This package provides a high performance and feature rich codec and
+encoding library for the MessagePack, CBOR, JSON and the Binc formats.")
+    (license license:expat)))
+
 (define-public go-github-com-valyala-fasthttp
   (package
     (name "go-github-com-valyala-fasthttp")