diff mbox series

[bug#69643] gnu: Add go-github-com-josharian-intern.

Message ID 87cys4iwu2.fsf@troyfigiel.com
State New
Headers show
Series [bug#69643] gnu: Add go-github-com-josharian-intern. | expand

Commit Message

Troy Figiel March 5, 2024, 9:09 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-josharian-intern): New variable.
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: d79c88e8809d2079452fd276bf4d17eb16636ff9

Comments

Sharlatan Hellseher March 17, 2024, 12:19 a.m. UTC | #1
Hi,

Pushed as 6fda9cfd0f34498a66746a41078e29d2382f580a to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..d7d3ee34ad 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1010,6 +1010,31 @@  (define-public go-github-com-jinzhu-copier
 struct to another.")
     (license license:expat)))
 
+(define-public go-github-com-josharian-intern
+  (package
+    (name "go-github-com-josharian-intern")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/josharian/intern")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1za48ppvwd5vg8vv25ldmwz1biwpb3p6qhf8vazhsfdg9m07951c"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/josharian/intern"))
+    (home-page "https://github.com/josharian/intern")
+    (synopsis "String interning for Go")
+    (description
+     "This library defines functions to perform string interning in Go,
+storing only one copy of each unique string in memory.  All functions may be
+called concurrently with themselves and each other.")
+    (license license:expat)))
+
 (define-public go-github-com-k0kubun-pp
   (package
     (name "go-github-com-k0kubun-pp")