diff mbox series

[bug#71994] gnu: Add emacs-ob-racket.

Message ID 87cynnajz7.fsf@colimite.fr
State New
Headers show
Series [bug#71994] gnu: Add emacs-ob-racket. | expand

Commit Message

Sergiu Ivanov July 8, 2024, 5:09 p.m. UTC
Hello Nicolas,

Thank you for your comments!  I am attaching the updated patch to
this mail.


Nicolas Goaziou <mail@nicolasgoaziou.fr> [2024-07-08T11:51:19+0100]:
>
> Likewise, Org Babel and Org mode.
>
> I know, not every package definition follows that convention, but they
> ARE WRONG! ;)

I am happy to follow this convention!

I never know myself how to spell Org Babel and Org mode, and if both
were Emacs functions or variables, I would just write org-babel and
org-mode :-D

-
Sergiu

Comments

Nicolas Goaziou July 9, 2024, 8:06 a.m. UTC | #1
Hello,

Sergiu Ivanov <sivanov@colimite.fr> writes:

> Thank you for your comments!  I am attaching the updated patch to
> this mail.

Applied. Thank you!

> I never know myself how to spell Org Babel and Org mode, and if both
> were Emacs functions or variables, I would just write org-babel and
> org-mode :-D

Yes, that's the source of the confusion. Elisp symbols use hyphens, and
it is easy to conflate the language symbol with the concept. But the
Emacs manual is unambiguous about it. For example, its menu contains the
following entry:

  * Major Modes::         Text mode vs. Lisp mode vs. C mode...

Regards,
diff mbox series

Patch

From a5632cda19d42cf0c631dcbe5fa71e65e63d4be7 Mon Sep 17 00:00:00 2001
Message-ID: <a5632cda19d42cf0c631dcbe5fa71e65e63d4be7.1720458373.git.sivanov@colimite.fr>
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Sat, 6 Jul 2024 18:34:22 +0100
Subject: [PATCH] gnu: Add emacs-ob-racket.

* gnu/packages/emacs-xyz.scm (emacs-ob-racket): New variable.

Change-Id: I54e96f51f1615b737f34fb729da6f872e64c2ebe
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..366efa0778 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26400,6 +26400,27 @@  (define-public emacs-racket-mode
 It follows DrRacket concepts where applicable.")
       (license license:gpl2+))))
 
+(define-public emacs-ob-racket
+  (package
+    (name "emacs-ob-racket")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hasu/emacs-ob-racket")
+                    (commit version)))
+              (sha256
+               (base32
+                "0bqhxi1nikxwc0gyqsnxc7ya2s41vc06w39s24qz64kja8zqzzya"))
+              (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/hasu/emacs-ob-racket")
+    (synopsis "Org Babel support for Racket")
+    (description
+     "This package adds spport for working with Racket code blocks with
+Org Babel in Org mode.")
+    (license license:gpl3+)))
+
 (define-public emacs-grep-context
   (let ((commit "5a4e3efdf775755c1bbefcfe4b461c1166d81d7d")
         (revision "1"))

base-commit: 5ee2799cabba4b2d462ac064a98789d7bca07923
-- 
2.45.2