diff mbox series

[bug#38865] add package definition for liquid-dsp-1.3.2

Message ID 87c412487b95a94fcbb7b9cbc133ddb1bd9b7819.camel@librehacker.com
State Accepted
Headers show
Series [bug#38865] add package definition for liquid-dsp-1.3.2 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Christopher Howard Jan. 11, 2020, 6:42 a.m. UTC
I went ahead and attached the updated patch as originally requested, in
case it is needed. I copied in the description the other uploader had
used since that seemed much better. One difference between my
definition and the other one, is that I include fftw and fftwf as
package inputs. fftw is an optional dependency of liquid-dsp, which I
think does not change the API of liquid-dsp, but does affects the
backend performance.

As far as sdr.scm vs. ham-radio.scm: I am a licensed ham radio operator
(US General Class), but nevertheless SDR and DSP are really not
exclusive to ham radio. Liquid DSP, e.g., could be used in a lot of
non-licensed or commercial-licensed applications (referring to the
frequency license).

Comments

Ludovic Courtès Jan. 15, 2020, 9:03 p.m. UTC | #1
Hello,

Christopher Howard <christopher@librehacker.com> skribis:

> From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
> From: Christopher Howard <christopher@librehacker.com>
> Date: Fri, 10 Jan 2020 21:19:24 -0900
> Subject: [PATCH] gnu: Add liquid-dsp.
>
> * gnu/packages/sdr.scm (liquid-dsp): New variable

Thanks, I’ve added the file to ‘gnu/local.mk’ and committed.

Evan, I hope that’s fine with you!  The changes I noticed between both
patches are: Evan’s did not include a dependency on FFTW, and
Christopher’s lives in sdr.scm while Evan’s in ham-radio.scm.

Evan, let us know if it’s fine for the rest of your patches!

Thanks everyone,
Ludo’.
Evan Straw Jan. 15, 2020, 10:46 p.m. UTC | #2
Hi,
I think the only problem that this will introduce is that my redsea package definition in my third patch depends on the definition for liquid-dsp being in the same file, so an import will have to be added. I can submit a revision for this in a few hours when I get back on my PC, if needed.

--Evan

Jan 15, 2020 1:04:00 PM Ludovic Courtès <ludo@gnu.org>:

> Hello,
> 
> Christopher Howard <christopher@librehacker.com> skribis:
> 
> 
> > From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
> > From: Christopher Howard <christopher@librehacker.com>
> > Date: Fri, 10 Jan 2020 21:19:24 -0900
> > Subject: [PATCH] gnu: Add liquid-dsp.
> > 
> > * gnu/packages/sdr.scm (liquid-dsp): New variable
> > 
> 
> Thanks, I’ve added the file to ‘gnu/local.mk’ and committed.
> 
> Evan, I hope that’s fine with you! The changes I noticed between both
> patches are: Evan’s did not include a dependency on FFTW, and
> Christopher’s lives in sdr.scm while Evan’s in ham-radio.scm.
> 
> Evan, let us know if it’s fine for the rest of your patches!
> 
> Thanks everyone,
> Ludo’.
>
Ludovic Courtès Jan. 16, 2020, 8:59 a.m. UTC | #3
Hi Evan,

Evan Straw <evan.straw99@gmail.com> skribis:

> I think the only problem that this will introduce is that my redsea package definition in my third patch depends on the definition for liquid-dsp being in the same file, so an import will have to be added. I can submit a revision for this in a few hours when I get back on my PC, if needed.

Sure, no rush.  An option would be to move all your packages to sdr.scm
(“SDR” is a superset of “ham radio”, after all).  WDYT?

Thanks,
Ludo’.
Christopher Howard Jan. 16, 2020, 2:49 p.m. UTC | #4
Most of the things currently in and proposed for ham-radio.scm would
fit also under the category of SDR. The one exception would be the
"chirp" package, which is not precisely an SDR application, but a tool
for reprogramming radios. But it might be close enough to be
practically lumped into that file. Strickly speaking, chirp is not
exclusively a ham radio tool other, but could be used by anyone
commercial or otherwise who needed to reprogram a radio.
diff mbox series

Patch

From 0064c61e7884c6f7d6356dfa22b04279bc460b2a Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Fri, 10 Jan 2020 21:19:24 -0900
Subject: [PATCH] gnu: Add liquid-dsp.

* gnu/packages/sdr.scm (liquid-dsp): New variable
---
 gnu/packages/sdr.scm | 58 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
 create mode 100644 gnu/packages/sdr.scm

diff --git a/gnu/packages/sdr.scm b/gnu/packages/sdr.scm
new file mode 100644
index 0000000000..f6c9050503
--- /dev/null
+++ b/gnu/packages/sdr.scm
@@ -0,0 +1,58 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sdr)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages algebra)
+  #:use-module (gnu packages autotools))
+
+(define-public liquid-dsp
+  (package
+    (name "liquid-dsp")
+    (version "1.3.2")
+    (source
+     (origin (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/jgaeddert/liquid-dsp.git")
+                   (commit (string-append "v" version))))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)))
+    (inputs
+     `(("fftw" ,fftw)
+       ("fftwf" ,fftwf)))
+    (home-page "https://liquidsdr.org")
+    (synopsis "Signal processing library for software-defined radios")
+    (description
+     "Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
+specifically for software-defined radios on embedded platforms.  The aim is to
+provide a lightweight DSP library that does not rely on a myriad of external
+dependencies or proprietary and otherwise cumbersome frameworks.  All signal
+processing elements are designed to be flexible, scalable, and dynamic,
+including filters, filter design, oscillators, modems, synchronizers, complex
+mathematical operations, and much more.")
+    (license license:expat)))
-- 
2.24.1