[bug#33388] gnu: u-boot: Update to 2018.11.

Message ID 87bm6rguxy.fsf@aikidev.net
State Accepted
Commit 0c7707d53e66839a2beae8c05eddc91ac5a6d5e1
Headers show
Series [bug#33388] gnu: u-boot: Update to 2018.11. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Vagrant Cascadian Nov. 14, 2018, 10:23 p.m. UTC
* gnu/packages/bootloaders.scm (u-boot): Update to 2018.11.
  (u-boot)[native-inputs]: Add lz4.
---
 gnu/packages/bootloaders.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Danny Milosavljevic Nov. 16, 2018, 8:05 p.m. UTC | #1
Pushed to master as commit 504910141efb9b586ec4ce5ceebdb3ced48488e9.

Thanks!

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index bce12d324..2fa50a89b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -34,6 +34,7 @@ 
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages disk)
   #:use-module (gnu packages firmware)
@@ -360,7 +361,7 @@  tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2018.09")
+    (version "2018.11")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -368,12 +369,13 @@  tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0s122kyz1svvs2yjzj4j9qravl3ra4vn0fjqgski7rlczqyg56w3"))))
+                "0znkwljfwwn4y7j20pzz4ilqw8znphrfxns0x1lwdzh3xbr96z3k"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
        ("dtc" ,dtc)
        ("flex" ,flex)
+       ("lz4" ,lz4)
        ("openssl" ,openssl)
        ("python-2" ,python-2)
        ("python2-coverage" ,python2-coverage)