[bug#35282,PATCHv2] gnu: docker: Patch paths of xz and docker-proxy.

Message ID 87bm17m37j.fsf_-_@gmail.com
State Accepted
Headers show
Series [bug#35282,PATCHv2] gnu: docker: Patch paths of xz and docker-proxy. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Maxim Cournoyer April 15, 2019, 8:19 p.m. UTC
Hello again,

Actually, the proposed change was not sufficient, as it would transform
reexec.Command -> exec.Command. The attached series fixes it (patch
0003, with the other rebased).
Thanks!

Maxim

Comments

Danny Milosavljevic April 15, 2019, 9:44 p.m. UTC | #1
LGTM!
Maxim Cournoyer April 16, 2019, 2:54 p.m. UTC | #2
Danny Milosavljevic <dannym@scratchpost.org> writes:

> LGTM!

Thanks for the review, Danny!

These changes are blocked by #35263, which modifies the go-build-system
slightly, so I will wait for that one to be reviewed and merged first
before closing this one.

Maxim
Maxim Cournoyer May 6, 2019, 1:43 a.m. UTC | #3
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> LGTM!
>
> Thanks for the review, Danny!
>
> These changes are blocked by #35263, which modifies the go-build-system
> slightly, so I will wait for that one to be reviewed and merged first
> before closing this one.
>
> Maxim

Push as commit 59781b32d8.

Thanks!

Maxim
Ricardo Wurmus May 6, 2019, 2:48 p.m. UTC | #4
T460s laptop <maxim.cournoyer@gmail.com> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>>
>>> LGTM!
>>
>> Thanks for the review, Danny!
>>
>> These changes are blocked by #35263, which modifies the go-build-system
>> slightly, so I will wait for that one to be reviewed and merged first
>> before closing this one.
>>
>> Maxim
>
> Push as commit 59781b32d8.

I’m closing this.

Patch

From 9809ec36652d4949af65eb75755e9dd6d8da5c40 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sat, 13 Apr 2019 22:58:55 -0400
Subject: [PATCH 7/7] gnu: docker: Refer to xz by its absolute path.

* gnu/packages/docker.scm (docker)[inputs]: Add xz.
[phases]{patch-paths}: Patch the reference to xz.
---
 gnu/packages/docker.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 16bc812dd7..43071775e4 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -371,6 +371,9 @@  built-in registry server of Docker.")
                 (string-append "var userlandProxyCommandName = \""
                                (assoc-ref inputs "docker-proxy")
                                "/bin/proxy\"\n")))
+             (substitute* "pkg/archive/archive.go"
+               (("string\\{\"xz")
+                (string-append "string{\"" (assoc-ref inputs "xz") "/bin/xz")))
              (let ((source-files (filter (lambda (name)
                                            (not (string-contains name "test")))
                                          (find-files "." "\\.go$"))))
@@ -531,7 +534,8 @@  built-in registry server of Docker.")
        ("runc" ,runc)
        ("util-linux" ,util-linux)
        ("lvm2" ,lvm2)
-       ("xfsprogs" ,xfsprogs)))
+       ("xfsprogs" ,xfsprogs)
+       ("xz" ,xz)))
     (native-inputs
      `(("eudev" ,eudev)      ; TODO: Should be propagated by lvm2 (.pc -> .pc)
        ("go" ,go)
-- 
2.20.1