diff mbox series

[bug#38950] Add chipmunk2d

Message ID 87blrhu6up.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#38950] Add chipmunk2d | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Nicolas Goaziou Jan. 5, 2020, 5:54 p.m. UTC
Hello,

The following patch adds Chipmunk2D.

Feedback welcome.

Regards,

Comments

Ludovic Courtès Jan. 17, 2020, 1:03 p.m. UTC | #1
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

>>From b1d239f57cf870fa525d2429069ec60993af1b4c Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Sun, 5 Jan 2020 18:52:49 +0100
> Subject: [PATCH] gnu: Add chipmunk2d.
>
> * gnu/packages/game-development.scm (chipmunk2d): New variable.

LGTM, thanks!

Ludo’.
Nicolas Goaziou Jan. 17, 2020, 8:19 p.m. UTC | #2
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:
>
>>>From b1d239f57cf870fa525d2429069ec60993af1b4c Mon Sep 17 00:00:00 2001
>> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> Date: Sun, 5 Jan 2020 18:52:49 +0100
>> Subject: [PATCH] gnu: Add chipmunk2d.
>>
>> * gnu/packages/game-development.scm (chipmunk2d): New variable.
>
> LGTM, thanks!

I changed the name to "chipmunk", as upstream uses both names, and every
distribution I could check uses this instead of "chipmunk2d".

I then applied the patch as d6ab5f4fa71a965c4e0dffd5eecb7a4345c9c89f.

Thank you for the review.

Regards,
diff mbox series

Patch

From b1d239f57cf870fa525d2429069ec60993af1b4c Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sun, 5 Jan 2020 18:52:49 +0100
Subject: [PATCH] gnu: Add chipmunk2d.

* gnu/packages/game-development.scm (chipmunk2d): New variable.
---
 gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7aef6b09d2..58623c4a4a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2029,3 +2029,31 @@  environments and virtual creatures.  It is currently used in many
 computer games, 3D authoring tools and simulation tools.")
     ;; Software is dual-licensed.
     (license (list license:lgpl2.1+ license:expat))))
+
+(define-public chipmunk2d
+  (package
+    (name "chipmunk2d")
+    (version "7.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/slembcke/Chipmunk2D.git")
+             (commit (string-append "Chipmunk-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f                      ;no test
+       #:configure-flags '("-DBUILD_STATIC=OFF"
+                           "-DBUILD_DEMOS=OFF")))
+    (inputs
+     `(("freeglut" ,freeglut)
+       ("libxmu" ,libxmu)
+       ("libxrandr" ,libxrandr)))
+    (home-page "http://chipmunk2d.net/")
+    (synopsis "Fast and lightweight 2D game physics library")
+    (description "Chipmunk2D is a simple, lightweight, fast and
+portable 2D rigid body physics library written in C.")
+    (license license:expat)))
-- 
2.24.1