diff mbox series

[bug#40303] gnu: Add emacs-flycheck-rust.

Message ID 87blog2c4b.fsf@asu.edu
State Accepted
Headers show
Series [bug#40303] gnu: Add emacs-flycheck-rust. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 29, 2020, 1:17 a.m. UTC
Hi Guix,

flycheck-rust provides flycheck integration for rust.

Thanks!

John

Comments

Nicolas Goaziou March 30, 2020, 5:13 p.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> Subject: [PATCH] gnu: Add emacs-flycheck-rust.
>
> * gnu/packages/emacs-xyz.scm (emacs-flycheck-rust): New variable.

I made a full sentence out of the description, removed "emac-seq"
dependency and pushed your patch as
5199be620f2a8f42fd5427ad000f8f215a852426.

I didn't activate the tests because those require "cargo" executable to
be available, which was, IMO, too much of a native input.

Thank you!

Regards,
diff mbox series

Patch

>From 8f65e7352b60cbdeab63697e638d7295c7d9360f Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:26:13 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-rust.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-rust): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..38157f4432 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21776,3 +21777,30 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-flycheck-rust
+  (package
+    (name "emacs-flycheck-rust")
+    (version "1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/flycheck/flycheck-rust")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1fh6j5w2387nh2fwwjphkhq17cgj5m2q5k0fhidvgc2w65lzbr1r"))))
+    (inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-let-alist" ,emacs-let-alist)
+       ("emacs-seq" ,emacs-seq)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/flycheck/flycheck-rust")
+    (synopsis "Better Rust/Cargo support for Flycheck")
+    (description
+     "Configures Flycheck automatically for the current Cargo project.")
+    (license license:gpl3+)))
-- 
2.26.0