diff mbox series

[bug#40746] New package: r-brms

Message ID 87blnkreg8.fsf@ericcbrown.com
State Accepted
Headers show
Series [bug#40746] New package: r-brms | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Eric Brown April 21, 2020, 4:28 p.m. UTC
Dear Guix:

Please see attached diff for r-brms.

Best regards,
Eric

Comments

Marius Bakke May 30, 2020, 5:54 p.m. UTC | #1
Hello,

This patch has gone stale, sorry about that.

Can you rebase it on 'master'?

Eric Brown <ecbrown@ericcbrown.com> writes:

> From 6d9b9202a5c2c45bd30b8764c740aee291274c83 Mon Sep 17 00:00:00 2001
> From: Eric Brown <ecbrown@ericcbrown.com>
> Date: Tue, 21 Apr 2020 11:13:11 -0500
> Subject: [PATCH] gnu: Add r-brms.
>
> * gnu/packages/cran.scm (r-brms): New variable.

[...]

> +    (home-page
> +     "https://github.com/paul-buerkner/brms")
> +    (synopsis
> +     "Bayesian Regression Models using 'Stan'")

The line breaks here are unnecessary.

> +    (description
> +     "Fit Bayesian generalized (non-)linear multivariate multilevel models
> +using 'Stan' for full Bayesian inference. A wide range of distributions and
> +link functions are supported, allowing users to fit -- among others -- linear,
> +robust linear, count data, survival, response times, ordinal, zero-inflated,
> +hurdle, and even self-defined mixture models all in a multilevel context.
> +Further modeling options include non-linear and smooth terms, auto-correlation
> +structures, censored data, meta-analytic standard errors, and quite a few
> +more. In addition, all parameters of the response distribution can be
> +predicted in order to perform distributional regression. Prior specifications
> +are flexible and explicitly encourage users to apply prior distributions that
> +actually reflect their beliefs. Model fit can easily be assessed and compared
> +with posterior predictive checks and leave-one-out cross-validation.")

Please use two spaces between sentences, as suggested by 'guix lint'.

> +    (license license:gpl2)))

I don't see any files mentioning 'GPL 2 only', so this should probably
be 'gpl2+', i.e. "GPL 2 or any later version".

Can you send an updated patch?  Thanks in advance.  :-)
diff mbox series

Patch

From 6d9b9202a5c2c45bd30b8764c740aee291274c83 Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Tue, 21 Apr 2020 11:13:11 -0500
Subject: [PATCH] gnu: Add r-brms.

* gnu/packages/cran.scm (r-brms): New variable.
---
 gnu/packages/cran.scm | 52 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..13251652d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,55 @@  evaluated interactively.")
 Bayes factors, posterior model probabilities, and normalizing constants in
 general, via different versions of bridge sampling.")
     (license license:gpl2+)))
+
+(define-public r-brms
+  (package
+    (name "r-brms")
+    (version "2.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "brms" version))
+       (sha256
+        (base32
+         "1699lwkklfhjz7fddawlig552g2zvrc34mqwrzqjgl35r9fm08gs"))))
+    (properties `((upstream-name . "brms")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)
+       ("r-backports" ,r-backports)
+       ("r-bayesplot" ,r-bayesplot)
+       ("r-bridgesampling" ,r-bridgesampling)
+       ("r-coda" ,r-coda)
+       ("r-future" ,r-future)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-glue" ,r-glue)
+       ("r-loo" ,r-loo)
+       ("r-matrix" ,r-matrix)
+       ("r-matrixstats" ,r-matrixstats)
+       ("r-mgcv" ,r-mgcv)
+       ("r-nleqslv" ,r-nleqslv)
+       ("r-nlme" ,r-nlme)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rstan" ,r-rstan)
+       ("r-rstantools" ,r-rstantools)
+       ("r-shinystan" ,r-shinystan)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+     "https://github.com/paul-buerkner/brms")
+    (synopsis
+     "Bayesian Regression Models using 'Stan'")
+    (description
+     "Fit Bayesian generalized (non-)linear multivariate multilevel models
+using 'Stan' for full Bayesian inference. A wide range of distributions and
+link functions are supported, allowing users to fit -- among others -- linear,
+robust linear, count data, survival, response times, ordinal, zero-inflated,
+hurdle, and even self-defined mixture models all in a multilevel context.
+Further modeling options include non-linear and smooth terms, auto-correlation
+structures, censored data, meta-analytic standard errors, and quite a few
+more. In addition, all parameters of the response distribution can be
+predicted in order to perform distributional regression. Prior specifications
+are flexible and explicitly encourage users to apply prior distributions that
+actually reflect their beliefs. Model fit can easily be assessed and compared
+with posterior predictive checks and leave-one-out cross-validation.")
+    (license license:gpl2)))
-- 
2.26.2