diff mbox series

bug#42725: [PATCH] drawpile package (sans upnp)

Message ID 87bljfhssq.fsf@gmail.com
State Accepted
Headers show
Series bug#42725: [PATCH] drawpile package (sans upnp) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Oleg Pykhalov Aug. 13, 2020, 8:08 a.m. UTC
Hi,

Apologies for delay and thank you for the patch!

Pushed to master as 9ac2a4ee3424dd216b1b67056968e0585197952a with
following changes:
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index dabd297c40..c7fefbd57d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1439,15 +1439,15 @@  Automated palette selection is supported.")
   (package
     (name "drawpile")
     (version "2.1.17")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/drawpile/Drawpile/archive/"
-                           version
-                           ".tar.gz"))
-       (sha256
-        (base32
-         "0brscm95nay31xa1c02n1w144gg9hm8pxwa9sfnis0x5dj2nkrb7"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/drawpile/Drawpile")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08w8vad8pw4a8kkshys1kd2kjvzpj62klxxxp904rx0qazw5hl80"))))
     (build-system qt-build-system)
     (arguments
      '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
@@ -1462,7 +1462,7 @@  Automated palette selection is supported.")
        ("libsodium" ,libsodium)
        ("libvpx" ,libvpx)
        ("libxi" ,libxi)
-       ;("miniupnpc" ,miniupnpc) ;; TODO segfaults for some reason
+       ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
        ("qtbase" ,qtbase)
        ("qtkeychain" ,qtkeychain)
        ("qtmultimedia" ,qtmultimedia)
@@ -1470,9 +1470,8 @@  Automated palette selection is supported.")
        ("qtx11extras" ,qtx11extras)))
     (home-page "https://drawpile.net")
     (synopsis "Collaborative drawing program")
-    (description
-"Drawpile is a drawing program that lets you share the canvas with other users
-in real time.
+    (description "Drawpile is a drawing program that allows share the canvas
+with other users in real time.
 
 Some feature highlights:
 @itemize
@@ -1486,5 +1485,5 @@  Some feature highlights:
 @item Supports OpenRaster file format
 @item Encrypted connections using SSL
 @item Automatic port forwarding with UPnP
-@end itemize")
+@end itemize\n")
     (license license:gpl3+)))