diff mbox series

[bug#51980] Adding xlispstat.scm

Message ID 87bl2fc3up.fsf@Ginko.local.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#51980] Adding xlispstat.scm | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Frank Pursel Nov. 19, 2021, 8:01 p.m. UTC
From d86ba6d5ed609cbe8b8814a13468e1410f8af726 Mon Sep 17 00:00:00 2001
From: Frank Pursel <purself@yahoo.com>
Date: Fri, 19 Nov 2021 11:55:02 -0800
Subject: [PATCH] Adding xlispstat.scm

---
 gnu/packages/xlispstat.scm | 83 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 83 insertions(+)
 create mode 100644 gnu/packages/xlispstat.scm
diff mbox series

Patch

diff --git a/gnu/packages/xlispstat.scm b/gnu/packages/xlispstat.scm
new file mode 100644
index 0000000000..94f5b9863b
--- /dev/null
+++ b/gnu/packages/xlispstat.scm
@@ -0,0 +1,83 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Frank Pursel <purself@yahoo.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages xlispstat)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages maths)
+  #:use-module (gnu packages shells))
+
+(define-public xlispstat
+  (let ((xlispstat-version "3.52.23")
+        (guix-revision "0")
+        (commit "f1bea6053df658ee48612bf1f63c35de99e2c649"))
+    (package
+      (name "xlispstat")
+      (version (git-version xlispstat-version guix-revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jhbadger/xlispstat")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1p0cmgy19kbkxia139cb5w9dnkp2cdqp5n3baag6cq3prn3n71mf"))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:parallel-build? #f
+         #:parallel-tests? #f
+         #:tests? #f
+         #:configure-flags
+         (list "--with-gcc")))
+      (inputs
+       `(("tcsh" ,tcsh)
+         ("libx11" ,libx11)
+         ("libxmu" ,libxmu)
+         ("libxext" ,libxext)
+         ("libxpm" ,libxpm)
+         ("libxaw" ,libxaw)
+         ("ncurses" ,ncurses)
+         ("gnuplot" ,gnuplot)))
+      (native-inputs `(("pkg-config" ,pkg-config)))
+      (synopsis "Statistical analysis environment with interactive graphics
+based on lisp")
+      (description "XLISP-STAT is a statistical environment based on a dialect
+of the Lisp language called XLISP.  To facilitate statistical computations,
+standard Lisp functions for addition, logarithms, etc., have been modified to
+operate on lists and arrays of numbers, and a number of basic statistical
+functions have been added.  Many of these functions have been written in Lisp,
+and additional functions can be added easily by a user.  Several basic forms
+of plots, including histograms, scatterplots, rotatable plots and scatterplot
+matrices are provided.  These plots support various forms of interactive
+highlighting operations and can be linked so points highlighted in one plot
+will be highlighted in all linked plots.  Interactions with the plots are
+controlled by the mouse, menus and dialog boxes.  An object-oriented
+programming system is used to allow menus, dialogs, and the response to mouse
+actions to be customized.")
+      (home-page "http://homepage.divms.uiowa.edu/~luke/xls/xlsinfo/")
+      (license expat))))
+
+;; See also https://www.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/impl/xlspstat/
+
+;; xlispstat