diff mbox series

[bug#53075,1/41] gnu: rust-rbw: adding rust-zeroize-1.4

Message ID 87bl0nslcz.fsf@ngraves.fr
State Accepted
Headers show
Series [bug#53075,1/41] gnu: rust-rbw: adding rust-zeroize-1.4 | expand

Commit Message

Nicolas Graves Jan. 7, 2022, 1:39 p.m. UTC

Comments

Nicolas Goaziou Jan. 19, 2022, 1:29 p.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> From 117ac2e745d1e9e2122bdf5859ae2b2781ca01c4 Mon Sep 17 00:00:00 2001
> From: Nicolas Graves <ngraves@ngraves.fr>
> Date: Thu, 6 Jan 2022 23:16:42 +0100
> Subject: [PATCH 02/42] rust-rbw dependencies : adding rust-zeroize-1.4

Thank you. First some general notes about your patches.

The first thing is that your patch set should have gone under the same
bug number. You created more than 40 bugs for rbw. You may want to look
at "Contributing" section of the Guix manual for details.

Also, commit messages are normalized in Guix. You should look at what
I wrote instead of yours to get a feel about it.

Eventually, descriptions should consist of full sentences.

Now about this patch.

Unless under exceptional circumstances, we don't add a new package for
a change below the first non-zero digit. In this case, the common way is
to simply update rust-zeroize-1 to 1.4.3.

Therefore, I dropped this patch and did the above.

Regards,
diff mbox series

Patch

From 117ac2e745d1e9e2122bdf5859ae2b2781ca01c4 Mon Sep 17 00:00:00 2001
From: Nicolas Graves <ngraves@ngraves.fr>
Date: Thu, 6 Jan 2022 23:16:42 +0100
Subject: [PATCH 02/42] rust-rbw dependencies : adding rust-zeroize-1.4

---
 gnu/packages/crates-io.scm | 56 ++++++++++++++++++++++++++++----------
 1 file changed, 42 insertions(+), 14 deletions(-)

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fb400cf3fc..43c8456b32 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Jacob Hrbek <kreyren@rixotstudio.cz>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Graves Nicolas <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1345,7 +1346,7 @@  (define-public rust-aes-gcm-0.6
         ("rust-block-cipher" ,rust-block-cipher-0.7)
         ("rust-ghash" ,rust-ghash-0.3)
         ("rust-subtle" ,rust-subtle-2)
-        ("rust-zeroize" ,rust-zeroize-1))
+        ("rust-zeroize" ,rust-zeroize-1.1))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
         ("rust-criterion-cycles-per-byte"
@@ -1379,7 +1380,7 @@  (define-public rust-aes-gcm-0.5
         ("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6)
         ("rust-ghash" ,rust-ghash-0.2)
         ("rust-subtle" ,rust-subtle-2)
-        ("rust-zeroize" ,rust-zeroize-1))))))
+        ("rust-zeroize" ,rust-zeroize-1.1))))))
 
 (define-public rust-aes-soft-0.6
   (package
@@ -13538,7 +13539,7 @@  (define-public rust-curve25519-dalek-3
          ("rust-rand-core" ,rust-rand-core-0.5)
          ("rust-serde" ,rust-serde-1)
          ("rust-subtle" ,rust-subtle-2)
-         ("rust-zeroize" ,rust-zeroize-1))))
+         ("rust-zeroize" ,rust-zeroize-1.1))))
     (home-page "https://dalek.rs/curve25519-dalek")
     (synopsis "Group operations on ristretto255 and Curve25519")
     (description
@@ -16743,7 +16744,7 @@  (define-public rust-ed25519-dalek-1
          ("rust-serde" ,rust-serde-1)
          ("rust-serde-bytes" ,rust-serde-bytes-0.11)
          ("rust-sha2" ,rust-sha2-0.9)
-         ("rust-zeroize" ,rust-zeroize-1))))
+         ("rust-zeroize" ,rust-zeroize-1.1))))
     (home-page "https://dalek.rs")
     (synopsis "Ed25519 EdDSA key generations, signing, and verification")
     (description
@@ -21766,7 +21767,7 @@  (define-public rust-ghash-0.3
     (arguments
      `(#:cargo-inputs
        (("rust-polyval" ,rust-polyval-0.4)
-        ("rust-zeroize" ,rust-zeroize-1))
+        ("rust-zeroize" ,rust-zeroize-1.1))
        #:cargo-development-inputs
        (("rust-hex-literal" ,rust-hex-literal-0.1))))
     (home-page "https://github.com/RustCrypto/universal-hashes")
@@ -21792,7 +21793,7 @@  (define-public rust-ghash-0.2
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-polyval" ,rust-polyval-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
+        ("rust-zeroize" ,rust-zeroize-1.1))))))
 
 (define-public rust-gif-0.11
   (package
@@ -30461,7 +30462,7 @@  (define-public rust-merlin-2
          ("rust-hex" ,rust-hex-0.3)
          ("rust-keccak" ,rust-keccak-0.1)
          ("rust-rand-core" ,rust-rand-core-0.5)
-         ("rust-zeroize" ,rust-zeroize-1))))
+         ("rust-zeroize" ,rust-zeroize-1.1))))
     (home-page "https://docs.rs/merlin")
     (synopsis "Composable proof transcripts for public-coin arguments of
 knowledge")
@@ -31836,7 +31837,7 @@  (define-public rust-nanorand-0.5
      `(#:skip-build? #true              ;error with pre-release randomize
        #:cargo-inputs
        (("rust-getrandom" ,rust-getrandom-0.2)
-        ("rust-zeroize" ,rust-zeroize-1))
+        ("rust-zeroize" ,rust-zeroize-1.1))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
         ("rust-fastrand" ,rust-fastrand-1)
@@ -31866,7 +31867,7 @@  (define-public rust-nanorand-0.4
      `(#:skip-build? #true              ;error with pre-release randomize
        #:cargo-inputs
        (("rust-getrandom" ,rust-getrandom-0.2)
-        ("rust-zeroize" ,rust-zeroize-1))
+        ("rust-zeroize" ,rust-zeroize-1.1))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
         ("rust-fastrand" ,rust-fastrand-1)
@@ -34203,7 +34204,7 @@  (define-public rust-num-bigint-dig-0.6
          ("rust-rand" ,rust-rand-0.7)
          ("rust-serde" ,rust-serde-1)
          ("rust-smallvec" ,rust-smallvec-1)
-         ("rust-zeroize" ,rust-zeroize-1))))
+         ("rust-zeroize" ,rust-zeroize-1.1))))
     (home-page
       "https://github.com/dignifiedquire/num-bigint")
     (synopsis "Big integer implementation for Rust")
@@ -39197,7 +39198,7 @@  (define-public rust-polyval-0.4
      `(#:cargo-inputs
        (("rust-cfg-if" ,rust-cfg-if-0.1)
         ("rust-universal-hash" ,rust-universal-hash-0.4)
-        ("rust-zeroize" ,rust-zeroize-1))
+        ("rust-zeroize" ,rust-zeroize-1.1))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
         ("rust-criterion-cycles-per-byte"
@@ -39225,7 +39226,7 @@  (define-public rust-polyval-0.3
        #:cargo-inputs
        (("rust-cfg-if" ,rust-cfg-if-0.1)
         ("rust-universal-hash" ,rust-universal-hash-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
+        ("rust-zeroize" ,rust-zeroize-1.1))))))
 
 (define-public rust-pom-3
   (package
@@ -64015,7 +64016,7 @@  (define-public rust-win-crypto-ng-0.4
          ("rust-doc-comment" ,rust-doc-comment-0.3)
          ("rust-rand-core" ,rust-rand-core-0.5)
          ("rust-winapi" ,rust-winapi-0.3)
-         ("rust-zeroize" ,rust-zeroize-1))))
+         ("rust-zeroize" ,rust-zeroize-1.1))))
     (home-page "https://crates.io/crates/win-crypto-ng")
     (synopsis "Safe bindings to MS Windows Cryptography API Next
 Generation")
@@ -64811,7 +64812,7 @@  (define-public rust-zerocopy-derive-0.2
 crate.")
     (license license:bsd-3)))
 
-(define-public rust-zeroize-1
+(define-public rust-zeroize-1.1
   (package
     (name "rust-zeroize")
     (version "1.1.0")
@@ -64837,6 +64838,33 @@  (define-public rust-zeroize-1
 implementation that works everywhere, even WASM!")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-zeroize-1.4
+  (package
+    (name "rust-zeroize")
+    (version "1.4.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "zeroize" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "068nvl3n5hk6lfn5y24grf2c7anzzqfzjjccscq3md7rqp79v3fn"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-zeroize-derive" ,rust-zeroize-derive-1))))
+    (home-page "https://github.com/RustCrypto/utils/tree/master/zeroize")
+    (synopsis
+      "Securely clear secrets from memory.")
+    (description
+      "Securely clear secrets from memory with a simple trait built on stable Rust
+primitives which guarantee memory is zeroed using an operation will not be
+'optimized away' by the compiler.  Uses a portable pure Rust implementation that
+works everywhere, even WASM!")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-zeroize-derive-1
   (package
     (name "rust-zeroize-derive")
-- 
2.34.0