[bug#53733] gnu: Add emacs-flyspell-fu
Commit Message
Hi,
this patch adds the emacs-flyspell-fu package.
/Niklas
From 748e128b0808cf320653cd2b577033f9120236cc Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 2 Feb 2022 19:49:46 +0100
Subject: [PATCH] gnu: Add emacs-flyspell-fu
* gnu/packages/emacs-xyz.scm (emacs-flyspell-fu): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -26451,6 +26451,30 @@ (define-public emacs-flyspell-correct
Helm and Ivy.")
(license license:gpl3+)))
+(define-public emacs-spell-fu
+ ;; There are no tagged releases upstream on gitlab, instead we are using the
+ ;; most recent commit.
+ (let ((commit "50be652a6ec8590c3098f46094a92213623349c1") (revision "0"))
+ (package
+ (name "emacs-spell-fu")
+ (version (git-version "0.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/ideasman42/emacs-spell-fu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n7qwnirvkh2aprb7l1wj9rywdsn33a7s32716m3afcvy7z9pyh4"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/ideasman42/emacs-spell-fu")
+ (synopsis "Fast highlighting of misspelled words")
+ (description
+ "This is a light weight spell checker for Emacs,
+that runs from the syntax highlighter without starting external processes.")
+ (license license:gpl3+))))
+
(define-public emacs-org-emms
(let ((commit "07a8917f3d628c32e5de1dbd118ac08203772533")
(revision "1"))
--
2.34.0