diff mbox series

bug#55129: [PATCH] gnu: Add xschem

Message ID 87bkwfsz1b.fsf@gnu.org
State Accepted
Headers show
Series bug#55129: [PATCH] gnu: Add xschem | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès May 2, 2022, 4:02 p.m. UTC
Hi,

Konstantinos Agiannis <agiannis.kon@gmail.com> skribis:

> ---
>  gnu/packages/engineering.scm | 46 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)

Pushed with a commit log and the cosmetic changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9d06b77c27..0ef1870a50 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3692,12 +3692,11 @@  (define-public xschem
          (modify-phases %standard-phases
            (delete 'configure)
            (add-before 'build 'setenv
-             (lambda _
-               (setenv "CC"
-                       ,(cc-for-target))
+             (lambda* (#:key outputs #:allow-other-keys)
+               (setenv "CC" ,(cc-for-target))
                (invoke "./configure"
                        (string-append "--prefix="
-                                      (assoc-ref %outputs "out"))) #t)))))
+                                      (assoc-ref outputs "out"))))))))
       (synopsis "Hierarchical schematic editor")
       (description
        "Xschem is an X11 schematic editor written in C and focused on