diff mbox series

[bug#60502] gnu: guile-ssh: Update to 0.16.2.

Message ID 87bkngofst.fsf@gmail.com
State New
Headers show
Series [bug#60502] gnu: guile-ssh: Update to 0.16.2. | expand

Commit Message

Artyom V. Poptsov Jan. 2, 2023, 8:13 p.m. UTC
Hello,

this patch updates Guile-SSH to 0.16.2.
Changelog for this version:

--8<---------------cut here---------------start------------->8---
* Changes in version 0.16.2 (2023-01-02)
** Bugfix in test "string->public-key, ECDSA"
The test used to explicitly compare libssh version with "9" so it would always
fail on platforms with libssh 0.10.  Now the test does numerical comparison
and uses "ecdsa-p256" on platforms that have libssh 0.9 or later version.

Reported by Vagrant Cascadian, here:
<https://github.com/artyom-poptsov/guile-ssh/issues/34>

* Changes in version 0.16.1 (2022-12-31)
** Disable the tests that require DSA algorithm by default
When DSA support is disabled in libssh (which is the default state since
libssh 0.10) all DSA-related Guile-SSH procedures will fail.  Now Guile-SSH
disables by default all the tests that are require the DSA algorithm support
by default.

Although those changes do not affect the Guile-SSH API directly, users should
be aware that DSA support will be removed altogether in the next major libssh
release.

Reported by Vagrant Cascadian, here:
<https://github.com/artyom-poptsov/guile-ssh/issues/34>
** Add '--enable-dsa' Autoconf option
'configure.ac' now has '--enable-dsa' option that allows to enable DSA public
key algorithm support in Guile-SSH.
** (ssh version): 'dsa-support?': New procedure
** guix.scm: Use libssh 0.10.0
The development GNU Guix environment now uses libssh 0.10.0.
--8<---------------cut here---------------end--------------->8---

As there's no '--enable-dsa' option passed to the Guile-SSH 'configure'
script, DSA-related tests are disabled; it means that libssh can be
upgraded to 0.10 without breaking Guile-SSH build.

I tested Guile-SSH with libssh 0.10 myself; here's the GNU Guix development
package recipe I used, for reference:
https://github.com/artyom-poptsov/guile-ssh/blob/master/guix.scm

Thanks,
avp

Comments

Mathieu Othacehe Jan. 8, 2023, 3:08 p.m. UTC | #1
Hello Artyom,

> this patch updates Guile-SSH to 0.16.2.

The package builds and the Guix test suite is passing, so let's go.

Thanks,

Mathieu
diff mbox series

Patch

From b9eae3e887bbfee8051264dc86395ba98fe3433e Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 2 Jan 2023 23:06:34 +0300
Subject: [PATCH] gnu: guile-ssh: Update to 0.16.2.

* gnu/packages/ssh.scm (guile-ssh): Update to 0.16.2.
---
 gnu/packages/ssh.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 65280bc4da..2f6874f811 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -318,7 +318,7 @@  (define-public openssh-sans-x
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.16.0")
+    (version "0.16.2")
     (home-page "https://github.com/artyom-poptsov/guile-ssh")
     (source (origin
               (method git-fetch)
@@ -328,7 +328,7 @@  (define-public guile-ssh
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ka5ayrg7kysx3bi5d8s0z6n12sdc06qp9gc4k9h2mlw3vz187ny"))))
+                "1rp5y1xjmsxplrzl0yf23g6rdjsw7ryh5pxs4pydpsryjjdwnf84"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (arguments
-- 
2.34.1