diff mbox series

[bug#60369,v2] gnu: Add eweouz.

Message ID 87bkm859at.fsf_-_@josefsson.org
State New
Headers show
Series [bug#60369,v2] gnu: Add eweouz. | expand

Commit Message

Simon Josefsson Feb. 5, 2023, 5:08 p.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:

> Hi Simon,
>
> Simon Josefsson <simon@josefsson.org> skribis:
>
>> While the package builds and works for me, I would appreciate a review
>> so I can learn -- I wrote this without understanding anything of what I
>> was doing, but merely pattern-matched things against other existing
>> packages that looked relevant.
>
> Let’s see.

Hi.  Thank you for reviewing this.

>> +(define-public eweouz
>> +  (package
>> +    (name "eweouz")
>
> Rather “emacs-eweouz” (info "(guix) Package Naming").

Okay.  The package provides non-emacs tools too, but I agree
emacs-eweouz is more appropriate since few are likely to use the tools
outside of the Emacs context.

>> +    (build-system gnu-build-system)
>> +    (arguments
>> +     `(#:tests? #f
>
> Please add a short comment saying why tests are disabled.

I re-enabled the tests now.  Upstream doesn't ship any tests, but at
least we shouldn't disable them in case there is ever a new version that
adds self-test.

>> +       (modify-phases %standard-phases
>> +         (replace 'bootstrap
>> +           (lambda _ (invoke "autoreconf" "-vif") #t))
>
> Is this needed?  The default ‘bootstrap’ phase does that, roughly.

It appears to be needed.  The eweouz tarball contains autogen.sh:

aclocal
autoheader
automake --copy --add-missing --foreign
autoconf
./configure --enable-maintainer-mode "$@"

And guix build seems to prefer invoking autogen.sh over autoreconf,
which causes this failure:

starting phase `bootstrap'
running './autogen.sh'
patch-shebang: ./autogen.sh: changing `/bin/sh' to `/gnu/store/4y5m9lb8k3qkb1y9m02sw9w9a6hacd16-bash-minimal-5.1.8/bin/sh'
configure.ac:10: installing './compile'
configure.ac:4: installing './install-sh'
configure.ac:4: installing './missing'
src/Makefile.am: installing './depcomp'
./autogen.sh: ./configure: /bin/sh: bad interpreter: No such file or directory
error: in phase 'bootstrap': uncaught exception:
%exception #<&invoke-error program: "./autogen.sh" arguments: () exit-status: 126 term-signal: #f stop-signal: #f> 
phase `bootstrap' failed after 0.6 seconds
command "./autogen.sh" failed with status 126

> You can omit the trailing #t too.

Nice catch, fixed.

>> +    (synopsis "Emacs interface to Evolution Data Server")
>> +    (description
>> +     "eweouz is an tool for looking up contacts from Evolution Data Server
>> +from Emacs. It is similar to BBDB, except much, much simpler.")
>> +    (license license:gpl2)))
>
> Might be ‘gpl2+’, unless it explicitly states “version 2 only”.

The majority is GPLv2-only.  The essential files in eweouz are the
following:

src/eweouz-dump-addressbook.c    GPLv2-only
src/eweouz-write-addressbook.c   GPLv2-only
lisp/eweouz.el                   GPLv2-only
lisp/vcard.el                    GPLv2+

Is there a way to express that?  I can't seem to find any documentation
for the (license...) clause (or am I missing it?), but I added both
licenses now and a comment.

> That’s all I have to say!  Overall it’s looking good.  :-)
>
> Could you send an updated patch?

See attached.

/Simon

Comments

Simon Josefsson April 28, 2023, 8:35 a.m. UTC | #1
Does anyone have further feedback on the second version of this patch?

/Simon
Nicolas Goaziou May 3, 2023, 12:59 p.m. UTC | #2
Hello,

Thank you.

> +    (arguments

You should use G-expressions from here:

(list
 #:modules '(...)
 #:imported-modules `(...)
 #:configure-flags
 #~(list (string-append ... (emacs:elpa-directory #$output))))
 #:phases
 #~(modify-phases ...)

> +         (add-after 'enter-lisp-dir 'emacs-patch-variables
> +           (lambda* (#:key outputs #:allow-other-keys)

This is not necessary: lambda _

> +             (make-file-writable "eweouz.el")

I think you can remove this line.

> +             (substitute* "eweouz.el"
> +               (("\\(setq eweouz-helper-dirs '\\(")
> +                (format #f "(setq eweouz-helper-dirs '(~s "
> +                        (string-append (assoc-ref outputs "out")
> +                                       "/libexec/eweouz"))))))

You should use emacs:emacs-substitute-variables here.

> +         (add-after 'emacs-patch-variables 'emacs-expand-load-path
> +           (assoc-ref emacs:%standard-phases 'expand-load-path))
> +         (add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
> +           (assoc-ref emacs:%standard-phases 'add-install-to-native-load-path))
> +         (add-after 'emacs-add-install-to-native-load-path 'emacs-install
> +           (assoc-ref emacs:%standard-phases 'install))
> +         (add-after 'emacs-install 'emacs-build
> +           (assoc-ref emacs:%standard-phases 'build))
> +         (add-after 'emacs-install 'emacs-make-autoloads
> +           (assoc-ref emacs:%standard-phases 'make-autoloads)))))
> +    (native-inputs
> +     (list autoconf
> +           automake
> +           emacs-minimal
> +           pkg-config))
> +    (inputs
> +     (list evolution-data-server))
> +    (home-page "https://tracker.debian.org/pkg/eweouz")
> +    (synopsis "Emacs interface to Evolution Data Server")
> +    (description
> +     "eweouz is an tool for looking up contacts from Evolution Data
> Server

Typo and capitalization: Eweouz is a tool...

> +from Emacs. It is similar to BBDB, except much, much simpler.")

You should separate sentences with two spaces.

> +    ;; Most things are GPLv2-only although lisp/vcard.el is GPLv2+.
> +    (license (list license:gpl2 license:gpl2+))))

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 24f79d8bd21fc7e4687c89bc920b33d6bf62cba9 Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Sun, 5 Feb 2023 18:06:08 +0100
Subject: [PATCH] gnu: Add eweouz.

* gnu/packages/emacs-xyz.scm (eweouz): New variable.
---
 gnu/packages/emacs-xyz.scm | 66 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 66 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d30696c7be..17d09a858d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -122,6 +122,7 @@ 
 ;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2022-2023 Simon Josefsson <simon@josefsson.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3155,6 +3156,71 @@  (define-public emacs-bbdb-vcard
 (BBDB).  Version 2.1 vCards are converted into version 3.0 on import.")
       (license license:gpl2+))))
 
+(define-public emacs-eweouz
+  (package
+    (name "emacs-eweouz")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       ;; README's git://git.err.no/eweouz is gone
+       (uri (string-append "mirror://debian/pool/main/e/eweouz/"
+                           "eweouz_" version ".tar.xz"))
+       (file-name (string-append name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "192zl3dyphhvcrvn65bqsrc4h6zks8b747lp6pqbpbmsqy4g4mr8"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:modules ((guix build gnu-build-system)
+                  ((guix build emacs-build-system) #:prefix emacs:)
+                  (guix build utils)
+                  (guix build emacs-utils))
+       #:imported-modules (,@%gnu-build-system-modules
+                           (guix build emacs-build-system)
+                           (guix build emacs-utils))
+       #:configure-flags
+       (list (string-append "--with-lispdir="
+                            (emacs:elpa-directory %output)))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'bootstrap
+           (lambda _ (invoke "autoreconf" "-vif")))
+         (add-after 'compress-documentation 'enter-lisp-dir
+           (lambda _ (chdir "lisp/")))
+         (add-after 'enter-lisp-dir 'emacs-patch-variables
+           (lambda* (#:key outputs #:allow-other-keys)
+             (make-file-writable "eweouz.el")
+             (substitute* "eweouz.el"
+               (("\\(setq eweouz-helper-dirs '\\(")
+                (format #f "(setq eweouz-helper-dirs '(~s "
+                        (string-append (assoc-ref outputs "out")
+                                       "/libexec/eweouz"))))))
+         (add-after 'emacs-patch-variables 'emacs-expand-load-path
+           (assoc-ref emacs:%standard-phases 'expand-load-path))
+         (add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
+           (assoc-ref emacs:%standard-phases 'add-install-to-native-load-path))
+         (add-after 'emacs-add-install-to-native-load-path 'emacs-install
+           (assoc-ref emacs:%standard-phases 'install))
+         (add-after 'emacs-install 'emacs-build
+           (assoc-ref emacs:%standard-phases 'build))
+         (add-after 'emacs-install 'emacs-make-autoloads
+           (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+    (native-inputs
+     (list autoconf
+           automake
+           emacs-minimal
+           pkg-config))
+    (inputs
+     (list evolution-data-server))
+    (home-page "https://tracker.debian.org/pkg/eweouz")
+    (synopsis "Emacs interface to Evolution Data Server")
+    (description
+     "eweouz is an tool for looking up contacts from Evolution Data Server
+from Emacs. It is similar to BBDB, except much, much simpler.")
+    ;; Most things are GPLv2-only although lisp/vcard.el is GPLv2+.
+    (license (list license:gpl2 license:gpl2+))))
+
 (define-public emacs-beacon
   (package
     (name "emacs-beacon")
-- 
2.38.1