diff mbox series

[bug#65592] : Update sbcl to 2.3.8

Message ID 87bkeqj6w0.fsf@gmail.com
State New
Headers show
Series [bug#65592] : Update sbcl to 2.3.8 | expand

Commit Message

André A. Gomes Aug. 29, 2023, 1:49 p.m. UTC
Hi Guix,

Please find the patch attached.  Thanks.

Comments

Guillaume Le Vaillant Sept. 4, 2023, 1:32 p.m. UTC | #1
I applied a modified version of your patch (to remove the obsolete patch
from the sources) on the lisp-team branch.
When the CI machines have rebuilt the dependents, we'll merge the
lisp-team branch into the master branch.
Guillaume Le Vaillant Sept. 23, 2023, 9:16 a.m. UTC | #2
SBCL 2.3.8 didn't build on riscv64, so instead version 2.3.7 is used for
now. It has been merged in master at
4f35ff1275e05be31f5d41464ccf147e9dbfd016.
Let's close this issue and open a new one for a future update of SBCL
(maybe 2.3.9 will fix the build failure).
André A. Gomes Sept. 26, 2023, 9:17 a.m. UTC | #3
Guillaume Le Vaillant <glv@posteo.net> writes:

> SBCL 2.3.8 didn't build on riscv64, so instead version 2.3.7 is used for
> now. It has been merged in master at
> 4f35ff1275e05be31f5d41464ccf147e9dbfd016.
> Let's close this issue and open a new one for a future update of SBCL
> (maybe 2.3.9 will fix the build failure).

Hi Guillaume,

Just for future reference, is there a way for me to check whether a SBCL
builds on all platforms when sending a patch?  Thanks.
Guillaume Le Vaillant Sept. 27, 2023, 9:03 a.m. UTC | #4
André A. Gomes <andremegafone@gmail.com> skribis:

> Guillaume Le Vaillant <glv@posteo.net> writes:
>
>> SBCL 2.3.8 didn't build on riscv64, so instead version 2.3.7 is used for
>> now. It has been merged in master at
>> 4f35ff1275e05be31f5d41464ccf147e9dbfd016.
>> Let's close this issue and open a new one for a future update of SBCL
>> (maybe 2.3.9 will fix the build failure).
>
> Hi Guillaume,
>
> Just for future reference, is there a way for me to check whether a SBCL
> builds on all platforms when sending a patch?  Thanks.

For x86_64, i686, aarch64, armhf and powerpc64le, you can check on
<https://qa.guix.gnu.org/issue/ISSUE-NUMBER>.

However so far the CI doesn't have builds for riscv64, because it
doesn't have riscv64 hardware. Efraim Flashner <efraim@flashner.co.il>
has a riscv64 board with Guix on it, and he is the one who tried
building SBCL 2.3.8 and saw the failure.

If you are using a Guix system, you could also add the
qemu-binfmt-service-type to your system definition, which gives the
possibility to build packages for some other architectures with:

  guix build -s riscv64-linux PACKAGE-NAME

Unfortunately, qemu-binfmt has difficulties running SBCL on foreign
architectures, and building SBCL for aarch64 or riscv64 on a x86_64
machine fails with an error about a missing tty or something like that.
However, trying the build with qemu-binfmt can still be useful, because
if compilation fails before getting to the tty error, it usually
indicates that the package has an issue on this architecture.
Christopher Baines Sept. 27, 2023, 10:44 a.m. UTC | #5
Guillaume Le Vaillant <glv@posteo.net> writes:

> André A. Gomes <andremegafone@gmail.com> skribis:
>
>> Guillaume Le Vaillant <glv@posteo.net> writes:
>>
>>> SBCL 2.3.8 didn't build on riscv64, so instead version 2.3.7 is used for
>>> now. It has been merged in master at
>>> 4f35ff1275e05be31f5d41464ccf147e9dbfd016.
>>> Let's close this issue and open a new one for a future update of SBCL
>>> (maybe 2.3.9 will fix the build failure).
>>
>> Hi Guillaume,
>>
>> Just for future reference, is there a way for me to check whether a SBCL
>> builds on all platforms when sending a patch?  Thanks.
>
> For x86_64, i686, aarch64, armhf and powerpc64le, you can check on
> <https://qa.guix.gnu.org/issue/ISSUE-NUMBER>.

Note that we're lacking sufficient powerpc64 hardware to do QA for that
architecture.

> However so far the CI doesn't have builds for riscv64, because it
> doesn't have riscv64 hardware. Efraim Flashner <efraim@flashner.co.il>
> has a riscv64 board with Guix on it, and he is the one who tried
> building SBCL 2.3.8 and saw the failure.

We do however have RiscV hardware connected to the bordeaux build farm,
I've got a machine and there's also a second connected. We probably need
at least one more machine to enable the system for QA though.
diff mbox series

Patch

From 001395fa5fd21654cadb20e4f9daaa30e000396d Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Tue, 29 Aug 2023 16:48:10 +0300
Subject: [PATCH] gnu: sbcl: Update to 2.3.8.

* gnu/packages/lisp.scm (sbcl): Update to 2.3.8.
---
 gnu/packages/lisp.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 6f425a6e4a..db9c644144 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -433,17 +433,15 @@  (define-public clisp
 (define-public sbcl
   (package
     (name "sbcl")
-    (version "2.3.5")
+    (version "2.3.8")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
                            version "-source.tar.bz2"))
        (sha256
-        (base32 "11ji5n65l31249r0v7hm0wc0yk2ila0y746nj36xn1cxrwh0gjc9"))
+        (base32 "0a8dranh15gsbq51ssnvccl91mzqmgs5xsmwisz5hvlimjr725a2"))
        (modules '((guix build utils)))
-       ;; backport from upstream.
-       (patches (search-patches "sbcl-riscv-Make-contribs-build-again.patch"))
        (snippet
         '(begin
            ;; Don't force ARMv5.
-- 
2.41.0