diff mbox series

[bug#66643] gnu: icedove/wayland: Use wrap-program.

Message ID 87bkcugyky.fsf@gmail.com
State New
Headers show
Series [bug#66643] gnu: icedove/wayland: Use wrap-program. | expand

Commit Message

Aleksandr Vityazev Oct. 19, 2023, 8:13 p.m. UTC
Hi,

When $@ is used in a bash script without escaping, it causes files with
spaces in the name to fail to open. This patch fixes this for
icedove-wayland. You can also see this kind of thing in qemu.

https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/virtualization.scm?h=master#n417
I don't think you should use wrap-program there.
WDYT?



* gnu/packages/gnuzilla (icedove/wayland): Use wrap-program, since
"$@" must be escaped.

Thanks to ivan-p-sokolov@ya.ru for noticing the issue!
---
 gnu/packages/gnuzilla.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)


base-commit: c065da01ff956d3c2bdfc45a33d910e509a211d9
prerequisite-patch-id: ec4a09723b91089c8eb5b5269ae81272bb4d81b4
prerequisite-patch-id: 9680399593e3dcdb5b10ee646023efd1215942d9
prerequisite-patch-id: 66497a0079d0077e7b5001707d8211c525ea7193
prerequisite-patch-id: 4f512542ae5806d47054e063e3dd1df66258c530
prerequisite-patch-id: 48abb1e84ca8d85b23794222f8fa5b4d2dfa4699
prerequisite-patch-id: a7fdd2f87131ad73865389152d4a826df24fcae7
prerequisite-patch-id: 1600413a45a50114906f4390653c3fbb7f536a4c
prerequisite-patch-id: 51e95882782a53eda933e884fb5e80487ba52b9f
prerequisite-patch-id: 177b2873f4e77585c464ac3d24bec78d58f128bd
prerequisite-patch-id: 631a6785018f999fcbf7e22fb8e2aae9329ced55
prerequisite-patch-id: 1bd1b328f9e3c7119fed731ffd7e7d87ac33f0c2
prerequisite-patch-id: 79105270952c22f07255cb315da1db44f505b07b
prerequisite-patch-id: 9c5af3baa3dac6233837fb6eb0b7467b969caff4
prerequisite-patch-id: 1156b461c8622b5071656309b05c026abab0f277
prerequisite-patch-id: 8a5e3746b5092496884d50ef4359148ac9349a83
prerequisite-patch-id: 579e44cb67db2d0d3c6232c7c306457a0b5a1a27
prerequisite-patch-id: f5dc3c2782749512e23becb166db7aafacd0be1f
prerequisite-patch-id: 41717fac7367d7e596c093548408ab4bb7d11575
prerequisite-patch-id: 82761b9bede107314f9e75282e1851da281e1d53
prerequisite-patch-id: 4eaffd8b1788833c76590916476337e55ae234b0
prerequisite-patch-id: b501999eff4662ed2917dba3b934abd1a5e2252a
prerequisite-patch-id: d2b947c72b82c6366d8164f1d732a4d25c6cb4fa
prerequisite-patch-id: e1df80a774d3de676f01f262c68f506b0bc1ed92
prerequisite-patch-id: 1e2e9dfb8051b74814d7711e0247674a20329b1e
prerequisite-patch-id: 3dc346b9df988744c17f4c810753d8afcb00a642
prerequisite-patch-id: e2c517c1181b6b34eda2f660985dd6db280d886f
prerequisite-patch-id: cf256fc20be65ced1f1486423f4bbea768d686ae
prerequisite-patch-id: 4c8c9425dae8a721016c4e0e7ed9c2fbe3556d9e
prerequisite-patch-id: fb5c2f33b0ee041a46c6025d04271c3dbdb53d15
prerequisite-patch-id: c9d2a6a24a622955395ad090a0eb22598c16b23d
prerequisite-patch-id: eeeefc7040171849bdaa2c9cd9f47731c80287ea
prerequisite-patch-id: 56c4e80a78ecd8514c5d96c4492925ad57d4dd14
prerequisite-patch-id: ebee5547a41485f7ca26f93609f53ade60601f3f
prerequisite-patch-id: 9c816f74d4166f1be0964ea0ef27d602495cd9bb
prerequisite-patch-id: faae90b478e36eb4f2f17bde8782032b30e2e4db
prerequisite-patch-id: bf26fe3d5e2082445217490ec635e6e85b65247f
prerequisite-patch-id: 1722a64febdad4cfaff4a22c44d9661fcf0b6a5a
prerequisite-patch-id: a50461c3f84736992a9fdcc23c36920a6555d567
prerequisite-patch-id: 6dec4cc56ec808267f99ac5f1be941fabb28e126
prerequisite-patch-id: 741be4e6b815c817ceedff55ea6da159e5050524

Comments

Aleksandr Vityazev Nov. 29, 2023, 2 p.m. UTC | #1
Hello,

just a gentle ping -- could anyone review this patch?  If using
wrap-program isn't quite appropriate, I can fix it another way.
Aleksandr Vityazev Jan. 11, 2024, 11:05 p.m. UTC | #2
Hi,

Another month has passed since the last letter, I am sending another
ping, this time I added members of the mozilla team to the CC. The patch
is still working, but if it’s unnecessary, I can just close the thread.
Clément Lassieur Jan. 12, 2024, 12:48 a.m. UTC | #3
On Fri, Jan 12 2024, Aleksandr Vityazev wrote:

> Hi,
>
> Another month has passed since the last letter, I am sending another
> ping, this time I added members of the mozilla team to the CC. The patch
> is still working, but if it’s unnecessary, I can just close the thread.

Hey Aleksandr,

Sorry for not replying earlier.

Wouldn't putting quotes around $@ (like \"$@\") be enough?

Thanks,
Clément
Aleksandr Vityazev Jan. 12, 2024, 4:15 a.m. UTC | #4
On 2024-01-12 01:48, Clément Lassieur wrote:

> On Fri, Jan 12 2024, Aleksandr Vityazev wrote:
>
>> Hi,
>>
>> Another month has passed since the last letter, I am sending another
>> ping, this time I added members of the mozilla team to the CC. The patch
>> is still working, but if it’s unnecessary, I can just close the thread.
>
> Hey Aleksandr,
>
> Sorry for not replying earlier.

there's no need to apologize, it's okay. I often forget to add team
members in the CC field of an email.

>
> Wouldn't putting quotes around $@ (like \"$@\") be enough?
>

both options solve the problem, the proposed one is simpler, so you can
choose this one. I will send v2 patch in the next mail.
Clément Lassieur Jan. 12, 2024, 11:59 a.m. UTC | #5
On Fri, Jan 12 2024, Aleksandr Vityazev wrote:

> On 2024-01-12 01:48, Clément Lassieur wrote:
>
>> On Fri, Jan 12 2024, Aleksandr Vityazev wrote:
>>
>>> Hi,
>>>
>>> Another month has passed since the last letter, I am sending another
>>> ping, this time I added members of the mozilla team to the CC. The patch
>>> is still working, but if it’s unnecessary, I can just close the thread.
>>
>> Hey Aleksandr,
>>
>> Sorry for not replying earlier.
>
> there's no need to apologize, it's okay. I often forget to add team
> members in the CC field of an email.
>
>>
>> Wouldn't putting quotes around $@ (like \"$@\") be enough?
>>
>
> both options solve the problem, the proposed one is simpler, so you can
> choose this one. I will send v2 patch in the next mail.

Ok, the simpler the better!

Pushed, thanks.
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a367d7a00f..7a71fc8cb9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Baptiste Strazzul <bstrazzull@hotmail.fr>
 ;;; Copyright © 2022 SeerLite <seerlite@disroot.org>
+;;; Copyright © 2023 Aleksandr Vityazev <avityazew@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2076,14 +2077,11 @@  (define-public icedove/wayland
       #~(begin
           (use-modules (guix build utils))
           (let* ((exe (string-append #$output "/bin/icedove")))
-            (mkdir-p (dirname exe))
-            (call-with-output-file exe
-              (lambda (port)
-                (format port "#!~a
- MOZ_ENABLE_WAYLAND=1 exec ~a $@"
-                        #$(file-append bash-minimal "/bin/bash")
-                        #$(file-append icedove "/bin/icedove"))))
-            (chmod exe #o555)
+            (install-file #$(file-append icedove "/bin/icedove")
+                          (string-append #$output "/bin"))
+            (wrap-program exe
+              #:sh #$(file-append bash-minimal "/bin/bash")
+              '("MOZ_ENABLE_WAYLAND" "" = ("1")))
             ;; Provide the manual and .desktop file.
             (copy-recursively (string-append #$icedove "/share")
                               (string-append #$output "/share"))