diff mbox series

[bug#68649,2/3] gnu: Add python-zodbpickle.

Message ID 87bk9eidpu.fsf@troyfigiel.com
State New
Headers show
Series gnu: Add python-zodb. | expand

Commit Message

Troy Figiel Jan. 21, 2024, 9:12 p.m. UTC
* gnu/packages/python-web.scm (python-zodbpickle): New variable.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 91e60bad8b..4267b417c8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2689,6 +2689,34 @@  (define-public python-zconfig
 configuration-intensive applications.")
     (license license:zpl2.1)))
 
+(define-public python-zodbpickle
+  (package
+    (name "python-zodbpickle")
+    (version "3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "zodbpickle" version))
+       (sha256
+        (base32 "04fcmdx10lk5ww740avphd1fj5wic2bav9skkavhif670vkk5v5r"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (if tests?
+                          (invoke "zope-testrunner" "-vv" "--test-path=src"
+                                  "--all")
+                          (format #t "test suite not run~%")))))))
+    (native-inputs (list python-zope-testrunner))
+    (home-page "https://github.com/zopefoundation/zodbpickle")
+    (synopsis "Uniform pickling interface for @code{zodb}")
+    (description
+     "This package is a fork of the @code{pickle} module (and the
+supporting C extension) from both Python 3.2 and Python 3.3.  The fork adds
+support for the @code{noload} operations used by @code{zodb}.")
+    (license (list license:psfl license:zpl2.1))))
+
 (define-public python-zope-event
   (package
     (name "python-zope-event")