diff mbox series

[bug#69193] gnu: go-github-com-mesilliac-pulse-simple: Remove examples.

Message ID 87bk8fbaze.fsf@troyfigiel.com
State New
Headers show
Series [bug#69193] gnu: go-github-com-mesilliac-pulse-simple: Remove examples. | expand

Commit Message

Troy Figiel Feb. 17, 2024, 11:08 a.m. UTC
* gnu/packages/golang.scm (go-github-com-mesilliac-pulse-simple): Remove examples.
[arguments] <#:phases>: Add remove-examples phase.
---
 gnu/packages/golang.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)


base-commit: 91d80460296e2d5a01704d0f34fb966a45a165ae

Comments

Sharlatan Hellseher Feb. 19, 2024, 11:52 p.m. UTC | #1
Hi,

Pushed as 643900518d07144d7c1466e221cc02cc95dcf9b7 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 527b63d160..7b51ecc41a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9042,7 +9042,13 @@  (define-public go-github-com-mesilliac-pulse-simple
       (propagated-inputs
        (list pkg-config pulseaudio))
       (arguments
-       '(#:import-path "github.com/mesilliac/pulse-simple"))
+       (list
+        #:import-path "github.com/mesilliac/pulse-simple"
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'remove-examples
+                       (lambda* (#:key import-path #:allow-other-keys)
+                         (delete-file-recursively
+                          (string-append "src/" import-path "/examples")))))))
       (home-page "https://github.com/mesilliac/pulse-simple")
       (synopsis "Cgo bindings to PulseAudio's Simple API")
       (description