[bug#74329,03/10] gnu: Fix whitespace issues in Haskell package descriptions.

Message ID 87bjwlrlba.fsf@erlikon.ch
State New
Headers
Series None |

Commit Message

Gabriel Wicki Jan. 5, 2025, 9:20 p.m. UTC
  This mainly addresses `double-space after sentence end period' and `trailing
white space' issues.

* gnu/packages/haskell-check.scm (ghc-tasty-expected-failure,
ghc-quickcheck-classes-base, ghc-doctest-lib): Fix description.
* gnu/packages/haskell-web.scm (ghc-hxt-unicode): Fix description.
* gnu/packages/haskell-xyz.scm (ghc-fsnotify, ghc-gtk2hs-buildtools,
ghc-operational, ghc-commonmark, ghc-template-haskell): Fix description.

Change-Id: I5a71ad41bbddf1ad4c880dacc0a53992a38c71ad
---
 gnu/packages/haskell-check.scm | 32 +++++++++++++++-----------------
 gnu/packages/haskell-web.scm   |  2 +-
 gnu/packages/haskell-xyz.scm   | 12 ++++++------
 3 files changed, 22 insertions(+), 24 deletions(-)
  

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 6f6ac3fd08..e668706959 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -355,7 +355,7 @@  (define-public ghc-tasty-expected-failure
     (description
      "With the function @code{Test.Tasty.ExpectedFailure.expectFail} in the
 provided module @code{Test.Tasty.ExpectedFailure}, you can mark that you
-expect test cases to fail, and not to pass. This can be used for test-driven
+expect test cases to fail, and not to pass.  This can be used for test-driven
 development.")
     (license license:expat)))
 
@@ -1069,21 +1069,19 @@  (define-public ghc-quickcheck-classes-base
     (home-page "https://github.com/andrewthad/quickcheck-classes#readme")
     (synopsis "QuickCheck common typeclasses from `base`")
     (description
-      "This library is a minimal variant of `quickcheck-classes`
-that only provides laws for typeclasses from `base`. The main
-purpose of splitting this out is so that `primitive` can depend
-on `quickcheck-classes-base` in its test suite, avoiding the
-circular dependency that arises if `quickcheck-classes` is used
-instead. . This library provides QuickCheck properties to ensure
-that typeclass instances adhere to the set of laws that they are
-supposed to. There are other libraries that do similar things,
-such as `genvalidity-hspec` and `checkers`. This library differs
-from other solutions by not introducing any new typeclasses that
-the user needs to learn. . /Note:/ on GHC < 8.5, this library
-uses the higher-kinded typeclasses ('Data.Functor.Classes.Show1',
-'Data.Functor.Classes.Eq1', 'Data.Functor.Classes.Ord1', etc.),
-but on GHC >= 8.5, it uses `-XQuantifiedConstraints` to express
-these constraints more cleanly.")
+      "This library is a minimal variant of `quickcheck-classes` that only
+provides laws for typeclasses from `base`.  The main purpose of splitting this
+out is so that `primitive` can depend on `quickcheck-classes-base` in its test
+suite, avoiding the circular dependency that arises if `quickcheck-classes` is
+used instead.  This library provides QuickCheck properties to ensure that
+typeclass instances adhere to the set of laws that they are supposed to.
+There are other libraries that do similar things, such as `genvalidity-hspec`
+and `checkers`.  This library differs from other solutions by not introducing
+any new typeclasses that the user needs to learn.  @emph{Note:} on GHC < 8.5,
+this library uses the higher-kinded typeclasses
+(@code{Data.Functor.Classes.Show1}, @code{Data.Functor.Classes.Eq1},
+@code{Data.Functor.Classes.Ord1}, etc.), but on GHC >= 8.5, it uses
+`-XQuantifiedConstraints` to express these constraints more cleanly.")
     (license license:bsd-3)))
 
 (define-public ghc-doctest-lib
@@ -1101,7 +1099,7 @@  (define-public ghc-doctest-lib
     (home-page "https://hub.darcs.net/thielema/doctest-lib/")
     (synopsis "Parts of doctest exposed as library")
     (description
-      "Parts of doctest exposed as library. For use with the doctest-extract utility.")
+      "Parts of doctest exposed as library.  For use with the doctest-extract utility.")
     (license license:expat)))
 
 (define-public ghc-doctest-exitcode-stdio
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 540b167b7a..f211c870a3 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1508,7 +1508,7 @@  (define-public ghc-hxt-unicode
     (description
      "This package provides Unicode encoding and decoding functions for
 encodings used in the Haskell XML Toolbox.  ISO Latin 1-16, utf8, utf16, ASCII
-are supported. Decoding is done with lazy functions, errors may be detected or
+are supported.  Decoding is done with lazy functions, errors may be detected or
 ignored.")
     (license license:expat)))
 
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f8d68243ce..0a58ee4d24 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4404,7 +4404,7 @@  (define-public ghc-fsnotify
     (home-page "https://github.com/haskell-fswatch/hfsnotify")
     (synopsis "Cross platform library for file change notification")
     (description "Cross platform library for file creation, modification, and
-deletion notification. This library builds upon existing libraries for platform
+deletion notification.  This library builds upon existing libraries for platform
 specific Windows, Mac, and Linux file system event notification.")
     (license license:bsd-3)))
 
@@ -4745,10 +4745,10 @@  (define-public ghc-gtk2hs-buildtools
     (synopsis "Tools to build the Gtk2Hs suite of user interface libraries")
     (description
      "This package provides a set of helper programs necessary to build the
-Gtk2Hs suite of libraries. These tools include a modified c2hs binding tool
+Gtk2Hs suite of libraries.  These tools include a modified c2hs binding tool
 that is used to generate FFI declarations, a tool to build a type hierarchy
 that mirrors the C type hierarchy of GObjects found in glib, and a generator
-for signal declarations that are used to call back from C to Haskell. These
+for signal declarations that are used to call back from C to Haskell.  These
 tools are not needed to actually run Gtk2Hs programs.")
     (license license:gpl2)))
 
@@ -8302,7 +8302,7 @@  (define-public ghc-operational
      "Implementation of difficult monads made easy with operational semantics")
     (description
      "This library makes it easy to implement monads with tricky control
-flow. This is useful for: writing web applications in a sequential style,
+flow.  This is useful for: writing web applications in a sequential style,
 programming games with a uniform interface for human and AI players and easy
 replay capababilities, implementing fast parser monads, designing monadic
 DSLs, etc.")
@@ -15129,7 +15129,7 @@  (define-public ghc-commonmark
 
 Accurate information about source positions is available for all block and
 inline elements.  Thus the library can be used to create an accurate syntax
-highlighter or an editor with live preview. The parser has been designed for
+highlighter or an editor with live preview.  The parser has been designed for
 robust performance even in pathological cases that tend to cause stack
 overflows or exponential slowdowns in other parsers, with parsing speed that
 varies linearly with input length.")
@@ -15243,7 +15243,7 @@  (define-public ghc-template-haskell
     (synopsis "Support library for Template Haskell")
     (description
      "This package provides modules containing facilities for manipulating
-Haskell source code using Template Haskell. See
+Haskell source code using Template Haskell.  See
 @uref{http://www.haskell.org/haskellwiki/Template_Haskell} for more
 information.")
     (license license:bsd-3)))