bug#75241: [PATCH] gnu: gerbil: Don't target the build machine.

Message ID 87bjvbqcwj.fsf@gnu.org
State New
Headers
Series bug#75241: [PATCH] gnu: gerbil: Don't target the build machine. |

Commit Message

Ludovic Courtès Feb. 9, 2025, 4:51 p.m. UTC
  Adam Faiz <adam.faiz@disroot.org> skribis:

>>From 261ce5c615524ed80e6be7ddf7f903faa53b5154 Mon Sep 17 00:00:00 2001
> Message-ID: <261ce5c615524ed80e6be7ddf7f903faa53b5154.1735722848.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Wed, 1 Jan 2025 17:07:11 +0800
> Subject: [PATCH] gnu: gerbil: Don't target the build machine.
>
> * gnu/packages/scheme.scm (gerbil)[arguments]: Add configure-flag to not build
> with '-march=native'.

Applied with the change below, thanks!

Ludo'.
  

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 95d999eb46c..4c9ad0628b8 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1267,8 +1267,9 @@  (define-public gerbil
         (base32 "1dff14bzqkq6scyyhnwhc3ky96j6lr84mnghk4da0x6vifw7p0p1"))))
     (arguments
      (list
-      #:configure-flags
-      #~(list "--enable-march=")
+      ;; Do not build with '-march=native'.
+      #:configure-flags #~(list "--enable-march=")
+
       #:phases #~(modify-phases %standard-phases
                    (delete 'bootstrap)
                    (add-after 'set-paths 'set-cc