[bug#77453] gnu: sbcl-alive-lsp [fixes from @sharlatan comments]
Commit Message
1. Fixed version
2. Fixed inputs ident
3. Fixed synopsis and description
Also had typo in lsp start defun. Here is the proper one:
(defun lsp-lisp-alive-start-ls ()
"Start the alive-lsp."
(interactive)
(when-let (((lsp--port-available "localhost" lsp-lisp-alive-port)))
(lsp-async-start-process #'ignore #'ignore
(executable-find "guix")
"shell"
"sbcl"
"sbcl-alive-lsp"
;; "-D" "-f" "guix.scm" ;; when working on some sbcl project packed in guix
"--"
"sbcl"
"--eval"
"(require :asdf)"
"--eval"
"(asdf:load-system :alive-lsp)"
"--eval"
(format "(alive/server::start :port %s)"
lsp-lisp-alive-port))))
---
gnu/packages/lisp-xyz.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)
(define-public cl-alive-lsp
--
2.49.0
Message-ID: <87cyd8114t.fsf@gmail.com>
@@ -31781,27 +31781,26 @@ (define-public ecl-usocket
(define-public sbcl-alive-lsp
(package
(name "sbcl-alive-lsp")
- (version "0.0.1")
+ (version "0.2.11")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nobody-famous/alive-lsp")
- (commit "491251c2897d9251d04301061065e2c23171f6a0")))
+ (commit (string-append "v" version))))
(file-name (git-file-name "sbcl-alive-lsp" version))
(sha256
- (base32 "112zk8hkg71h7bbdmqfgxqblccb2bs8wcl6f7nrjjm1hy3cf1919"))))
+ (base32 "1dmgglrg7294vx8qacc5d2hkhfrids1iacihj2l8czrvwc3i19yz"))))
(build-system asdf-build-system/sbcl)
(inputs
- (list
- sbcl-usocket
- sbcl-cl-json
- sbcl-bordeaux-threads
- sbcl-flexi-streams))
+ (list sbcl-usocket
+ sbcl-cl-json
+ sbcl-bordeaux-threads
+ sbcl-flexi-streams))
(home-page "https://github.com/nobody-famous/alive-lsp")
- (synopsis "Common Lisp LSP: Alive")
- (description "This is the language server for Alive:
- The Average Lisp VSCode Environment.")
+ (synopsis "Common Lisp Alive LSP")
+ (description "Language Server Protocol implementation for use with the
+ @url{https://github.com/nobody-famous/alive, Alive} Visual Studio Code
extension")
(license license:unlicense)))