diff mbox series

[bug#70936,gnome-team,3/3] gnu: qemu: Disable more tests.

Message ID 87ae7ec753272f84daac81b184a23679e934cb6f.1715688922.git.liliana.prikler@gmail.com
State New
Headers show
Series Fix some broken tests. | expand

Commit Message

Liliana Marie Prikler May 14, 2024, 12:10 p.m. UTC
* gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
qtest/ahci-test and qemu-iotests/copy-before-write.
---
 gnu/packages/virtualization.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer May 15, 2024, 1:40 a.m. UTC | #1
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
> qtest/ahci-test and qemu-iotests/copy-before-write.
> ---
>  gnu/packages/virtualization.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 34cccd6550..5389af62f0 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -305,7 +305,12 @@ (define-public qemu
>                (substitute* "tests/qtest/meson.build"
>                  ;; These tests fail to get the expected number of tests
>                  ;; on arm platforms.
> -                (("'arm-cpu-features',") ""))))
> +                (("'arm-cpu-features',") "")
> +                ;; XXX: Why does this (sometimes) fail?

Someone reported it already upstream:
<https://gitlab.com/qemu-project/qemu/-/issues/2121>.  Please add a
reference to it.

> +                (("\\['ahci-test'\\]") "[]"))
> +              ;; This test appears to be missing permissions.
> +              ;; Very sus 🤔

How can it be missing permissions if it is sometimes working?  Perhaps
more something racy where the file hasn't been created yet.  I'd
personally rather not see emojis or comments of dubious utility ("Very
suspect") in the source.  Perhaps add a short excerpt of the error for
the next curious person.

> +              (delete-file "tests/qemu-iotests/tests/copy-before-write")))
>            #$@(if (target-riscv64?)
>                   '((add-after 'unpack 'disable-some-tests
>                       (lambda _

Otherwise, LGTM!
Maxim Cournoyer May 15, 2024, 1:41 a.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/virtualization.scm (qemu)[disable-unusable-tests]: Also disable
> qtest/ahci-test and qemu-iotests/copy-before-write.
> ---
>  gnu/packages/virtualization.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 34cccd6550..5389af62f0 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -305,7 +305,12 @@ (define-public qemu
>                (substitute* "tests/qtest/meson.build"
>                  ;; These tests fail to get the expected number of tests
>                  ;; on arm platforms.
> -                (("'arm-cpu-features',") ""))))
> +                (("'arm-cpu-features',") "")
> +                ;; XXX: Why does this (sometimes) fail?

Someone reported it already upstream:
<https://gitlab.com/qemu-project/qemu/-/issues/2121>.  Please add a
reference to it.

> +                (("\\['ahci-test'\\]") "[]"))
> +              ;; This test appears to be missing permissions.
> +              ;; Very sus 🤔

How can it be missing permissions if it is sometimes working?  Perhaps
more something racy where the file hasn't been created yet.  I'd
personally rather not see emojis or comments of dubious utility ("Very
suspect") in the source.  Perhaps add a short excerpt of the error for
the next curious person.

> +              (delete-file "tests/qemu-iotests/tests/copy-before-write")))
>            #$@(if (target-riscv64?)
>                   '((add-after 'unpack 'disable-some-tests
>                       (lambda _

Otherwise, LGTM, with the added reference to the upstream issue.  Thanks
for taking the time to address flaky tests!  They are a real drag when
left unchecked.
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 34cccd6550..5389af62f0 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -305,7 +305,12 @@  (define-public qemu
               (substitute* "tests/qtest/meson.build"
                 ;; These tests fail to get the expected number of tests
                 ;; on arm platforms.
-                (("'arm-cpu-features',") ""))))
+                (("'arm-cpu-features',") "")
+                ;; XXX: Why does this (sometimes) fail?
+                (("\\['ahci-test'\\]") "[]"))
+              ;; This test appears to be missing permissions.
+              ;; Very sus 🤔
+              (delete-file "tests/qemu-iotests/tests/copy-before-write")))
           #$@(if (target-riscv64?)
                  '((add-after 'unpack 'disable-some-tests
                      (lambda _