[bug#34258,1/2] gnu: Add python-discid.

Message ID 87a7jixibx.fsf@gmail.com
State Accepted
Headers show
Series [bug#34258,1/2] gnu: Add python-discid. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Jan. 30, 2019, 3:36 p.m. UTC
* gnu/packages/music.scm (python-discid): New variable.
---
 gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Marius Bakke Jan. 31, 2019, 9:06 p.m. UTC | #1
Gabriel Hondet <gabrielhondet@gmail.com> writes:

> * gnu/packages/music.scm (python-discid): New variable.

[...]

> * gnu/packages/music.scm (python-isrcsubmit): New variable.

I fixed the indentation, made some editorialization of the descriptions
(note that the Guile TexInfo implementation does not have @acronym yet)
and pushed both patches as <84243592fe..07c82daad4>.

Thank you!

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4943b901e..5a07ad4ae 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4076,6 +4077,41 @@  it provides a submission URL for adding the disc ID to the database and gathers
 ISRCs and the MCN (=UPC/EAN) from disc.")
     (license license:lgpl2.1+)))
 
+(define-public python-discid
+  (package
+    (name "python-discid")
+    (version "1.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "discid" version))
+        (sha256
+          (base32
+            "1fgp67nhqlbvhhwrcxq5avil7alpzw4s4579hlyvxzbphdnbz8vq"))))
+    (build-system python-build-system)
+    (inputs
+     `(("libdiscid" ,libdiscid)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-libdiscid
+           ;; Set path of libdiscid
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((discid (assoc-ref inputs "libdiscid")))
+               (substitute* "discid/libdiscid.py"
+                 (("lib_name = (.*)$" all name)
+                  (string-append "lib_name = \"" discid
+                                 "/lib/libdiscid.so.0\"\n")))))))))
+    (home-page "https://python-discid.readthedocs.io/")
+    (synopsis "Python binding of Libdiscid")
+    (description "This package provides a python binding of Libdiscid by
+Musicbrainz.  The main purpose is the calculation of an identifier for audio
+discs @url{http://musicbrainz.org/doc/Disc%20ID, Disc ID} to use for the
+@url{http://musicbrainz.org/, MusicBrainz database.  Additionally the disc
+@acronym{MCN, Media Catalog Number} and track @acronym{ISRC, Internation
+Standard Recording Code} can be extracted.}")
+    (license license:lgpl3+)))
+
 (define-public libmusicbrainz
   (package
     (name "libmusicbrainz")