diff mbox series

[bug#35699] gnu: Add emacs-evil-cleverparens

Message ID 87a7frfzfj.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#35699] gnu: Add emacs-evil-cleverparens | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

LaFreniere, Joseph May 12, 2019, 3:46 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-evil-cleverparens): New 
  variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

+modal editing with screwing up the structure of lisp code. 
Alternatives for
+verb commands which would are normally destructive (such as 
deletion) are
+provided.  Those alternative commands are and bound by default to 
their
+corresponding Evil keys.")
+      (license license:expat))))
--
2.21.0

Comments

Ludovic Courtès May 14, 2019, 10:19 a.m. UTC | #1
Hi,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-evil-cleverparens): New variable.

Your email client munged the patch so I had to fiddle a bit with it, but
anyway, I added a copyright line for you and applied it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm 
b/gnu/packages/emacs-xyz.scm
index 069bf3e1f6..c5f1a0103e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15557,3 +15557,30 @@  between \"frame-width\" and 
\"frame-height\", between \"public\",
 \"protected\" and \"private\" and between \"variable1\", 
 \"variable2\" through
 \"variableN\".")
     (license license:gpl2+)))
+
+(define-public emacs-evil-cleverparens
+  (let ((commit "8c45879d49bfa6d4e414b6c1df700a4a51cbb869")
+        (revision "1"))
+    (package
+      (name "emacs-evil-cleverparens")
+      (version (git-version "2017-07-17" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url 
"https://github.com/luxbock/evil-cleverparens.git")
+                      (commit commit)))
+                (sha256 (base32 
"0lhnybpnk4n2yhlcnj9zxn0vi5hpjfaqfhvyfy7ckzz74g8v7iyw"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-evil" ,emacs-evil)
+         ("emacs-paredit" ,emacs-paredit)
+         ("emacs-smartparens" ,emacs-smartparens)))
+      (home-page "https://github.com/luxbock/evil-cleverparens")
+      (synopsis "Emacs modal editing optimized for editing Lisp")
+      (description "@code{evil-clverparens} remaps Evil 
keybindings to allow