b/gnu/packages/emacs-xyz.scm
@@ -15557,3 +15557,30 @@ between \"frame-width\" and
\"frame-height\", between \"public\",
\"protected\" and \"private\" and between \"variable1\",
\"variable2\" through
\"variableN\".")
(license license:gpl2+)))
+
+(define-public emacs-evil-cleverparens
+ (let ((commit "8c45879d49bfa6d4e414b6c1df700a4a51cbb869")
+ (revision "1"))
+ (package
+ (name "emacs-evil-cleverparens")
+ (version (git-version "2017-07-17" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
"https://github.com/luxbock/evil-cleverparens.git")
+ (commit commit)))
+ (sha256 (base32
"0lhnybpnk4n2yhlcnj9zxn0vi5hpjfaqfhvyfy7ckzz74g8v7iyw"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)
+ ("emacs-paredit" ,emacs-paredit)
+ ("emacs-smartparens" ,emacs-smartparens)))
+ (home-page "https://github.com/luxbock/evil-cleverparens")
+ (synopsis "Emacs modal editing optimized for editing Lisp")
+ (description "@code{evil-clverparens} remaps Evil
keybindings to allow