diff mbox series

[bug#38103] Dracula emacs theme

Message ID 87a795xbc6.fsf@thinkpad.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#38103] Dracula emacs theme | expand

Commit Message

bluekeys@bluekeys.eu Nov. 9, 2019, 4:29 p.m. UTC
Hi,

Second attempt to attach the patch.

Comments

Marius Bakke Nov. 10, 2019, 8:14 p.m. UTC | #1
bluekeys@bluekeys.eu writes:

> Hi,
>
> Second attempt to attach the patch. 

Looks good!

[...]
  
> +(define-public emacs-dracula-theme
> +  (package
> +    (name "emacs-dracula-theme")
> +    (version (git-version "0" "0" "320cc8cfc67e33c86045ef3e79b7627b91b9b517"))
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/dracula/emacs.git")
> +             (commit "320cc8cfc67e33c86045ef3e79b7627b91b9b517")))

Could add a (let (commit ...)) binding for the commit hash so we don't
have to repeat it twice?  See the surrounding packages for examples.

Please also add a 'file-name' field here.

> +       (sha256
> +        (base32
> +         "0pzlwxsa823sbcf2nq2lw303cld2jc2siaaiafld0qc4xasg9zyn"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://draculatheme.com/emacs")
> +    (synopsis "A dark theme for emacs")

Just "Dark theme for Emacs", to appease 'guix lint emacs-dracula-theme'.

> +    (description
> +     "A dark theme for emacs and 50+ apps")

Can you expand a bit on the "50+ apps" part?  Perhaps something along
the lines of "Dracula is a dark color theme implemented for more than 50
different applications.  This package provides the Emacs theme."

Can you send an updated patch?  Thanks, and welcome!  :-)
Brett Gilio Dec. 10, 2019, 4:50 a.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> bluekeys@bluekeys.eu writes:
>
>> Hi,
>>
>> Second attempt to attach the patch. 
>
> Looks good!
>
> [...]
>   
>> +(define-public emacs-dracula-theme
>> +  (package
>> +    (name "emacs-dracula-theme")
>> +    (version (git-version "0" "0" "320cc8cfc67e33c86045ef3e79b7627b91b9b517"))
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/dracula/emacs.git")
>> +             (commit "320cc8cfc67e33c86045ef3e79b7627b91b9b517")))
>
> Could add a (let (commit ...)) binding for the commit hash so we don't
> have to repeat it twice?  See the surrounding packages for examples.
>
> Please also add a 'file-name' field here.
>
>> +       (sha256
>> +        (base32
>> +         "0pzlwxsa823sbcf2nq2lw303cld2jc2siaaiafld0qc4xasg9zyn"))))
>> +    (build-system emacs-build-system)
>> +    (home-page "https://draculatheme.com/emacs")
>> +    (synopsis "A dark theme for emacs")
>
> Just "Dark theme for Emacs", to appease 'guix lint emacs-dracula-theme'.
>
>> +    (description
>> +     "A dark theme for emacs and 50+ apps")
>
> Can you expand a bit on the "50+ apps" part?  Perhaps something along
> the lines of "Dracula is a dark color theme implemented for more than 50
> different applications.  This package provides the Emacs theme."
>
> Can you send an updated patch?  Thanks, and welcome!  :-)
>

Hi Marius and bluekeys!

I just wanted to bump this so we can get it pushed. If you would like
some help, bluekeys please do not hesitate to ask us either here or on
the #guix Freenode IRC.

Also, when you send your revised patch do include yourself in the
copyright section of the header! You deserve that designation for your
contribution.

Thanks!
Michael Rohleder June 2, 2020, 5:19 a.m. UTC | #3
close 38103

this has been added recently.
diff mbox series

Patch

From ef1394d995e1eb180c6cc51974aa82d42c7d67e5 Mon Sep 17 00:00:00 2001
From: bluekeys <git@bluekeys.eu>
Date: Tue, 5 Nov 2019 22:31:43 +0000
Subject: [PATCH] Create emacs-dracula-theme module

---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1be819728f..d04ae3d26a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8050,6 +8050,26 @@  known loosely as deftheme.  Many mode-specific customizations are included.")
        "@code{danneskjold-theme} is a high-contrast theme for Emacs.")
       (license license:gpl3+))))
 
+(define-public emacs-dracula-theme
+  (package
+    (name "emacs-dracula-theme")
+    (version (git-version "0" "0" "320cc8cfc67e33c86045ef3e79b7627b91b9b517"))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dracula/emacs.git")
+             (commit "320cc8cfc67e33c86045ef3e79b7627b91b9b517")))
+       (sha256
+        (base32
+         "0pzlwxsa823sbcf2nq2lw303cld2jc2siaaiafld0qc4xasg9zyn"))))
+    (build-system emacs-build-system)
+    (home-page "https://draculatheme.com/emacs")
+    (synopsis "A dark theme for emacs")
+    (description
+     "A dark theme for emacs and 50+ apps")
+    (license license:expat)))
+
 (define-public emacs-dream-theme
   (let* ((commit "107a11d74365046f28a1802a2bdb5e69e4a7488b")
          (revision "1"))
-- 
2.23.0