diff mbox series

[bug#38765] Add C++ bindings to Portaudio

Message ID 87a77d3957.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#38765] Add C++ bindings to Portaudio | expand

Commit Message

Nicolas Goaziou Dec. 27, 2019, 6:39 p.m. UTC
Hello,

The following patch enables C++ bindings for our Portaudio package.

Regards,

Comments

Efraim Flashner Dec. 28, 2019, 7:54 p.m. UTC | #1
LGTM!


On Fri, Dec 27, 2019 at 07:39:48PM +0100, Nicolas Goaziou wrote:
> Hello,
> 
> The following patch enables C++ bindings for our Portaudio package.
> 
> Regards,
> 
> -- 
> Nicolas Goaziou

> From a771f96fc319e1ece917532253c44b57494d0e32 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Fri, 27 Dec 2019 19:33:50 +0100
> Subject: [PATCH] gnu: portaudio: Add C++ bindings.
> 
> * gnu/packages/audio.scm (portaudio): Add C++ bindings, aka "portaudiocpp".
> ---
>  gnu/packages/audio.scm | 9 +++++++--
>  1 file changed, 7 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 76c59f33cc..73235ef292 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -2872,8 +2872,13 @@ portions of LAME.")
>         ("libtool" ,libtool)
>         ("pkg-config" ,pkg-config)))
>      (arguments
> -     '(#:tests? #f                    ;no 'check' target
> -       #:configure-flags '("--with-pic")
> +     '(#:tests? #f                      ;no 'check' target
> +       #:configure-flags '("--with-pic"
> +                           "--enable-cxx"
> +                           ;; XXX: The following prevents a build error
> +                           ;; because of missing depcomp when C++ bindings are
> +                           ;; requested.
> +                           "--disable-dependency-tracking")
>         #:phases
>         (modify-phases %standard-phases
>           ;; This is needed for linking the static libraries
> -- 
> 2.24.1
>
Nicolas Goaziou Dec. 28, 2019, 8:22 p.m. UTC | #2
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

> LGTM!

Pushed as 1ce6bfc21ce328d787df76c6ee132f9f828d098b. Thank you.

Regards,
diff mbox series

Patch

From a771f96fc319e1ece917532253c44b57494d0e32 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 27 Dec 2019 19:33:50 +0100
Subject: [PATCH] gnu: portaudio: Add C++ bindings.

* gnu/packages/audio.scm (portaudio): Add C++ bindings, aka "portaudiocpp".
---
 gnu/packages/audio.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 76c59f33cc..73235ef292 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2872,8 +2872,13 @@  portions of LAME.")
        ("libtool" ,libtool)
        ("pkg-config" ,pkg-config)))
     (arguments
-     '(#:tests? #f                    ;no 'check' target
-       #:configure-flags '("--with-pic")
+     '(#:tests? #f                      ;no 'check' target
+       #:configure-flags '("--with-pic"
+                           "--enable-cxx"
+                           ;; XXX: The following prevents a build error
+                           ;; because of missing depcomp when C++ bindings are
+                           ;; requested.
+                           "--disable-dependency-tracking")
        #:phases
        (modify-phases %standard-phases
          ;; This is needed for linking the static libraries
-- 
2.24.1