diff mbox series

[bug#40444] gnu: Add emacs-form-feed.

Message ID 87a73qzed1.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#40444] gnu: Add emacs-form-feed. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph April 5, 2020, 5:32 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Nicolas Goaziou April 5, 2020, 8:22 a.m. UTC | #1
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached.

Applied as a24744bd0a9860c5233483e91c8ddb430311f9b7. Thank you.

Regards,
diff mbox series

Patch

From 4906196f4b43b9cc9460b438bd553e7055a26f2e Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 5 Apr 2020 00:31:57 -0500
Subject: [PATCH] gnu: Add emacs-form-feed.

* gnu/packages/emacs-xyz.scm (emacs-form-feed): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cd2562103c..154d00e7ac 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1873,6 +1873,28 @@  environment set through Direnv.")
 that the binary uses instead of the actual binary contents.")
     (license license:gpl3+)))
 
+(define-public emacs-form-feed
+  (package
+    (name "emacs-form-feed")
+    (version "0.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/wasamasa/form-feed.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "171jna631b2iqcimfsik9c66gii8nc0zdb58m077w00rn7rcxbh2"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/wasamasa/form-feed")
+    (synopsis "Display ^L glyphs as horizontal lines")
+    (description
+     "This package provides a minor mode @code{form-feed-mode} to display page
+delimiters which usually appear as ^L glyphs on a single line as horizontal
+lines spanning the entire window.  The minor mode is suitable for inclusion
+into mode hooks and is intended to be used that way.")
+    (license license:gpl3+)))
+
 (define-public emacs-ggtags
   (package
     (name "emacs-ggtags")
-- 
2.26.0