diff mbox series

[bug#41566] gnu: Add emacs-erc-status-sidebar.

Message ID 87a71mvv6l.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41566] gnu: Add emacs-erc-status-sidebar. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder June 2, 2020, 6:27 a.m. UTC
Hi Marius,

thank you reviewing!

Marius Bakke <marius@gnu.org> writes:
> IIRC melpa.org purges old versions, so we should probably change to
> 'git-fetch' here.

done.

>> +    (license license:gpl3)))
>
> Well this is awkward, the LICENSE file is GPL3, but the headers in
> erc-status-sidebar.el actually uses the Expat license.  So this should
> be license:expat.

oh, good catch, I didnt notice!

Comments

Ludovic Courtès June 14, 2020, 9:05 p.m. UTC | #1
Hi Michael,

Michael Rohleder <mike@rohleder.de> skribis:

> From 5da5a1e7322dc00f8900724060de3d5fe2a826e0 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Tue, 2 Jun 2020 08:20:18 +0200
> Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.
>
> * gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)

This seems to address what Marius commented on so I went ahead and
applied it.  I followed up with small changes to placate ‘guix lint’.

Thanks,
Ludo’.
diff mbox series

Patch

From 5da5a1e7322dc00f8900724060de3d5fe2a826e0 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 2 Jun 2020 08:20:18 +0200
Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.

* gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b64a964916..76c67d859e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3280,6 +3280,31 @@  appropriate console.")
 IRC bouncer with ERC.")
     (license license:expat)))
 
+(define-public emacs-erc-status-sidebar
+  (let ((commit "ea4189a1dbfe60117359c36e681ad7c389e2968c")
+        (revision "1"))
+    (package
+      (name "emacs-erc-status-sidebar")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/drewbarbs/erc-status-sidebar.git")
+               (commit commit)))
+         (sha256
+          (base32 "1hwlhzgx03z8891sblz56zdp8zj0izh72kxykgcnz5rrkyc3vfi3"))))
+      (build-system emacs-build-system)
+      (propagated-inputs `(("emacs-seq" ,emacs-seq)))
+      (home-page "https://github.com/drewbarbs/erc-status-sidebar")
+      (synopsis "A hexchat-like activity overview for ERC channels")
+      (description
+       "This package is provides a hexchat-like status bar for joined
+channels in ERC.  It relies on the `erc-track' module, and displays
+all the same information erc-track does in the mode line, but in an
+alternative format.")
+      (license license:expat))))
+
 (define-public emacs-shut-up
   (package
     (name "emacs-shut-up")
-- 
2.26.2