diff mbox series

[bug#43900] gnu: Add python-dictdiffer.

Message ID 87a6wuu1j6.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#43900] gnu: Add python-dictdiffer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 10, 2020, 4:51 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Marius Bakke Oct. 13, 2020, 9:31 p.m. UTC | #1
Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> Patch file is attached.

Applied with a minor tweak to the description, as well as filling out
the home page.  I also added a copyright line for you.  Thanks!
diff mbox series

Patch

From 2f5a9bb39d4ecc453cd9e7313813c1ea037366aa Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Mon, 5 Oct 2020 20:43:32 -0500
Subject: [PATCH] gnu: Add python-dictdiffer.

* gnu/packages/python-xyz.scm (python-dictdiffer): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0670eb7e08..715048383e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21473,6 +21473,36 @@  randomness (including real life dice) and different wordlists (including
 cryptographically signed ones).")
     (license license:gpl3+)))
 
+(define-public python-dictdiffer
+  (package
+    (name "python-dictdiffer")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "dictdiffer" version))
+              (sha256
+               (base32
+                "1lk3qmy1hkaphk4n7ayfk0wl6m2yvd6r7qkam6yncqfzgkbc1phs"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-check-manifest" ,python-check-manifest)
+       ("python-coverage" ,python-coverage)
+       ("python-isort" ,python-isort)
+       ("python-mock" ,python-mock)
+       ("python-pydoctstyle" ,python-pydocstyle)
+       ("python-pytest-cache" ,python-pytest-cache)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-pep8" ,python-pytest-pep8)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-tox" ,python-tox)))
+    (home-page "")
+    (synopsis "Library to help diff and patch dictionaries")
+    (description
+     "Dictdiffer is a module that helps you to diff and patch dictionaries.")
+    (license license:expat)))
+
 (define-public pyzo
   (package
     (name "pyzo")
-- 
2.28.0