diff mbox series

[bug#47211] gnu: Add emacs-ivy-hydra.

Message ID 87a6r2rtwd.fsf@posteo.net
State Accepted
Headers show
Series [bug#47211] gnu: Add emacs-ivy-hydra. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev March 17, 2021, 9:50 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Jelle Licht March 22, 2021, 9:08 p.m. UTC | #1
Alexandr Vityazev <avityazev@posteo.org> writes:

> ---
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index c73b0df283..2f7918f910 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -27247,3 +27247,27 @@ and prefered services can easily be configured.")
>      (description
>       "This package adds a \"C-'\" binding to Ivy minibuffer that uses Avy.")
>      (license license:gpl3+)))
> +
> +(define-public emacs-ivy-hydra
> +  (package
> +    (name "emacs-ivy-hydra")
> +    (version "0.13.5")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://elpa.gnu.org/packages/"
> +             "ivy-hydra-" version ".tar"))
> +       (sha256
> +        (base32 "06rln9bnq5hli5rqlm47fb68b8llpqrmzwqqv4rn7mx3854i9a5x"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-ivy" ,emacs-ivy)
> +       ("emacs-hydra" ,emacs-hydra)))
> +    (home-page "https://github.com/abo-abo/swiper")
> +    (synopsis "Additional key bindings for Ivy")
> +    (description
> +     "This package provides the `hydra-ivy/body' command, which is a
> +quasi-prefix map, with many useful bindings.  These bindings are
> +shorter than usual, using mostly unprefixed keys.")
> +    (license license:gpl3+)))
> -- 
> 2.30.2
>
>
>
> -- 
>
> Alexandr Vityazev

Pushed to master as 6c1217c22c, same treatment as last patch.
Thanks!
 - Jelle
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c73b0df283..2f7918f910 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27247,3 +27247,27 @@  and prefered services can easily be configured.")
     (description
      "This package adds a \"C-'\" binding to Ivy minibuffer that uses Avy.")
     (license license:gpl3+)))
+
+(define-public emacs-ivy-hydra
+  (package
+    (name "emacs-ivy-hydra")
+    (version "0.13.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/"
+             "ivy-hydra-" version ".tar"))
+       (sha256
+        (base32 "06rln9bnq5hli5rqlm47fb68b8llpqrmzwqqv4rn7mx3854i9a5x"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-ivy" ,emacs-ivy)
+       ("emacs-hydra" ,emacs-hydra)))
+    (home-page "https://github.com/abo-abo/swiper")
+    (synopsis "Additional key bindings for Ivy")
+    (description
+     "This package provides the `hydra-ivy/body' command, which is a
+quasi-prefix map, with many useful bindings.  These bindings are
+shorter than usual, using mostly unprefixed keys.")
+    (license license:gpl3+)))