diff mbox series

[bug#55281] gnu: Add emacs-code-cells

Message ID 87a6bvg00k.fsf@posteo.net
State Accepted
Headers show
Series [bug#55281] gnu: Add emacs-code-cells | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund May 5, 2022, 9:08 p.m. UTC
Hi,

this is a patch for adding the emacs-code-cells package.

Best regards,
Niklas Eklund

Comments

Nicolas Goaziou June 22, 2022, 6:23 a.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> this is a patch for adding the emacs-code-cells package.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 92b9c62c7342d5d9b376c59a7cb5e12a55371cca Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 5 May 2022 21:09:19 +0200
Subject: [PATCH] gnu: Add emacs-code-cells.

* gnu/packages/emacs-xyz.scm (emacs-code-cells): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a928ac72f1..2f5cadb376 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30623,6 +30623,30 @@  (define-public emacs-blacken
 @command{python} buffers.")
     (license license:gpl3)))
 
+(define-public emacs-code-cells
+  ;; No tagged release upstream
+  (let ((commit "8660bdeedee360e5eb632f1eb1356eb09d7dfbee")
+        (revision "0"))
+    (package
+      (name "emacs-code-cells")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/astoff/code-cells.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0mvfsdlhc3znc0d2p8vm7apkbpvbs688wmwvd0sms33qly53f546"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/astoff/code-cells.el")
+      (synopsis "Emacs utilities for code split into cells, including Jupyter
+notebooks")
+      (description "This package lets you efficiently navigate, edit and
+execute code split into cells according to certain magic comments.")
+      (license license:gpl3+))))
+
 (define-public emacs-kibit-helper
   (package
     (name "emacs-kibit-helper")
-- 
2.34.0