diff mbox series

[bug#56214] Update GDAL to 3.5.0

Message ID 87a6a1vsh6.fsf@burningswell.com
State Accepted
Headers show
Series [bug#56214] Update GDAL to 3.5.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roman Scherer June 25, 2022, 12:25 p.m. UTC
Hello Guix,

I would like to update the GDAL library to v3.5.0.

Could you please review it?

Thanks, Roman.

Comments

Guillaume Le Vaillant June 25, 2022, 7:17 p.m. UTC | #1
I modified the commit message to use our standard format (see [1]), and
pushed the patch as d4c8e8b62fb9ef59e203e97cbb9bfa9e83389199.
Thanks.

[1] https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches
Roman Scherer June 25, 2022, 8:06 p.m. UTC | #2
Thanks Guillaume!

Guillaume Le Vaillant <glv@posteo.net> writes:

> [[PGP Signed Part:Undecided]]
> I modified the commit message to use our standard format (see [1]), and
> pushed the patch as d4c8e8b62fb9ef59e203e97cbb9bfa9e83389199.
> Thanks.
>
> [1] https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches
>
> [[End of PGP Signed Part]]
diff mbox series

Patch

From caccab6114293a9b4e3b2304de22de997a076a34 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sat, 25 Jun 2022 13:47:19 +0200
Subject: [PATCH] Update GDAL to 3.5.0

This patch updates GDAL to v3.5.0. I added 2 more dependencies to the package:

- curl (To be able to read rasters using vsicurl) [1]

- openssl (To enable Postgresql raster support, pkg-config was not detecting
libpq without openssl)

I also had to add the --without-jpeg12 option, because GDAL did not build with
it's internal libjpeg and libjpeg12 removed. I don't think we supported
libjpeg12 in the previous version, since the bundled code was removed and I
believe libjpeg-turbo does not provide this functionality.

[1] https://gdal.org/user/virtual_file_systems.html
---
 gnu/packages/geo.scm | 42 ++++++++++++++++++++----------------------
 1 file changed, 20 insertions(+), 22 deletions(-)

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7b29c55088..38df5ff537 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -113,6 +113,7 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages time)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages wxwidgets)
@@ -914,7 +915,7 @@  (define-public spatialite-gui
 (define-public gdal
   (package
     (name "gdal")
-    (version "3.3.3")
+    (version "3.5.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -922,7 +923,7 @@  (define-public gdal
                      version ".tar.gz"))
               (sha256
                (base32
-                "0nk09lws1hk873yn5f4wzqfvr82gm4hw3gq8w9g1h0kvf6j5x4i8"))
+                "0h7dgjx8nk3dd17wwqm2yjnaqciyrd2mz9gcjswpcnmap09wbzrs"))
               (modules '((guix build utils)))
               (snippet
                 `(begin
@@ -946,27 +947,23 @@  (define-public gdal
                              (string-append option "="
                                             (assoc-ref %build-inputs input))))))
          (list
-           ;; TODO: --with-pcidsk, --with-pcraster
-           (with "--with-freexl" "freexl")
-           (with "--with-libjson-c" "json-c")
-           (with "--with-png" "libpng")
-           (with "--with-webp" "libwebp")
-           (with "--with-gif" "giflib")
-           (with "--with-jpeg" "libjpeg-turbo")
-           (with "--with-libtiff" "libtiff")
-           (with "--with-geotiff" "libgeotiff")
-           (with "--with-libz" "zlib")
-           (with "--with-expat" "expat")
-           (with "--with-sqlite3" "sqlite")
-           "--with-pcre"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'fix-path
-           (lambda _
-             (substitute* "frmts/mrf/mrf_band.cpp"
-               (("\"../zlib/zlib.h\"") "<zlib.h>")))))))
+          ;; TODO: --with-pcidsk, --with-pcraster
+          (with "--with-expat" "expat")
+          (with "--with-freexl" "freexl")
+          (with "--with-geotiff" "libgeotiff")
+          (with "--with-gif" "giflib")
+          (with "--with-jpeg" "libjpeg-turbo")
+          (with "--with-libjson-c" "json-c")
+          (with "--with-libtiff" "libtiff")
+          (with "--with-libz" "zlib")
+          (with "--with-png" "libpng")
+          (with "--with-sqlite3" "sqlite")
+          (with "--with-webp" "libwebp")
+          "--without-jpeg12"
+          "--with-pcre"))))
     (inputs
-     (list expat
+     (list curl
+           expat
            freexl
            geos
            giflib
@@ -977,6 +974,7 @@  (define-public gdal
            libtiff
            libwebp
            netcdf
+           openssl
            pcre
            postgresql ; libpq
            proj
-- 
2.36.1