diff mbox series

bug#56321: [PATCH v2] gnu: Add breeze-gtk.

Message ID 87a69ec8nz.fsf@gnu.org
State Accepted
Headers show
Series bug#56321: [PATCH v2] gnu: Add breeze-gtk. | expand

Commit Message

Ludovic Courtès July 12, 2022, 9:39 p.m. UTC
Hi,

Samuel Fadel <samuel@nihil.ws> skribis:

> This adds the GTK port of the Breeze theme. This v2 of the patch
> includes more accurate licensing infomation.
>
> * gnu/packages/kde-plasma.scm (breeze-gtk): Added package.

Applied with the changes below.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index dde74b084d..4ae6ac9484 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -31,11 +31,14 @@  (define-module (gnu packages kde-plasma)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages web))
 
 (define-public breeze
   (package
@@ -95,10 +98,7 @@  (define-public breeze-gtk
              (base32
               "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
    (build-system qt-build-system)
-   (arguments
-    `(#:phases
-      (modify-phases %standard-phases
-                     (delete 'check)))) ; Test phase not defined
+   (arguments '(#:tests? #f))                     ;no 'test' target
    (native-inputs
     (list breeze extra-cmake-modules sassc python python-pycairo))
    (home-page "https://invent.kde.org/plasma/breeze")
@@ -306,3 +306,4 @@  (define-public libksysguard
 with a ksysguardd daemon, which may also run on a remote system.")
     (license license:gpl3+)))
 
+