diff mbox series

[bug#57387] gnu: Add restartd.

Message ID 87a67qsl9y.fsf@ngraves.fr
State New
Headers show
Series [bug#57387] gnu: Add restartd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 26, 2022, 10:16 p.m. UTC
* gnu/packages/admin.scm (restartd): New variable.
---
 gnu/packages/admin.scm                        |  54 ++++
 ...td-add-error-handling-for-robustness.patch | 242 ++++++++++++++++++
 .../patches/restartd-fix-compilation.patch    |  53 ++++
 3 files changed, 349 insertions(+)
 create mode 100644 gnu/packages/patches/restartd-add-error-handling-for-robustness.patch
 create mode 100644 gnu/packages/patches/restartd-fix-compilation.patch

--
2.37.2

--
Best regards,
Nicolas Graves

Comments

M Aug. 28, 2022, 5:38 p.m. UTC | #1
This merge seems ok to me.

Thanks,
Maxime (not a committer)
Mathieu Othacehe Sept. 11, 2022, 2:53 p.m. UTC | #2
Hello,

> * gnu/packages/admin.scm (restartd): New variable.

I have the following error when trying to build the package:

--8<---------------cut here---------------start------------->8---
2 out of 8 hunks FAILED -- saving rejects to file restartd.c.rej
source is at 'restartd-0.2.3-1.7044125-checkout'
applying '/gnu/store/gayczr3cvcxlqafxz9pclk6b8jhxhl75-restartd-fix-compilation.patch'...
applying '/gnu/store/d1sllhia0ninbfrq9agw2272dwm1v103-restartd-add-error-handling-for-robustness.patch'...
Backtrace:
           5 (primitive-load "/gnu/store/skbm6f65x56bhq5sd8w7fys5q49…")
In ice-9/eval.scm:
    619:8  4 (_ #(#(#<directory (guile-user) 7ffff3fd7c80> "res…") #))
In ice-9/boot-9.scm:
    142:2  3 (dynamic-wind #<procedure 7ffff3f862c0 at ice-9/eval.s…> …)
In ice-9/eval.scm:
    619:8  2 (_ #(#(#<directory (guile-user) 7ffff3fd7c80>)))
In srfi/srfi-1.scm:
    634:9  1 (for-each #<procedure apply-patch (a)> _)
In guix/build/utils.scm:
    762:6  0 (invoke "/gnu/store/z39hnrwds1dgcbpfgj8dnv2cngjb2xbl-p…" …)

guix/build/utils.scm:762:6: In procedure invoke:
ERROR:
  1. &invoke-error:
      program: "/gnu/store/z39hnrwds1dgcbpfgj8dnv2cngjb2xbl-patch-2.7.6/bin/patch"
      arguments: ("--force" "--no-backup-if-mismatch" "-p1" "--input" "/gnu/store/d1sllhia0ninbfrq9agw2272dwm1v103-restartd-add-error-handling-for-robustness.patch")
      exit-status: 1
      term-signal: #f
      stop-signal: #f
--8<---------------cut here---------------end--------------->8---

Mathieu
Nicolas Graves Sept. 11, 2022, 6:13 p.m. UTC | #3
On 2022-09-11 16:53, Mathieu Othacehe wrote:
> I have the following error when trying to build the package:
>
> --8<---------------cut here---------------start------------->8---
> 2 out of 8 hunks FAILED -- saving rejects to file restartd.c.rej

I can't reproduce, don't have the error when compiling again with
--check. Can you provide contents of restartd.c.rej?

Thanks!

Nicolas
Mathieu Othacehe Sept. 12, 2022, 7:36 a.m. UTC | #4
Hello,

> I can't reproduce, don't have the error when compiling again with
> --check. Can you provide contents of restartd.c.rej?

Please find it attached.

Mathieu
Nicolas Graves Sept. 13, 2022, 8:45 a.m. UTC | #5
> Please find it attached.
Thanks!

I don't understand why there should be a reject, just by looking at the
patches, I don't see why these hunks would collide.

I don't have a clue on how to fix this. I'll merge both locally
and regenerating a single patch that by definition can't collide.
Mathieu Othacehe Sept. 14, 2022, 7:48 a.m. UTC | #6
Hello Nicolas,

>  ...td-add-error-handling-for-robustness.patch | 242 ++++++++++++++++++
>  .../patches/restartd-fix-compilation.patch    |  53 ++++

Both patches also need to be added to the dist_patch_DATA variable of
gnu/local.mk.

Thanks,

Mathieu
Nicolas Graves Feb. 3, 2024, 2:07 p.m. UTC | #7
Hi Mathieu,

Done in a rebased v3, you can ignore the v2. Sorry for the time it took.

Nicolas

On 2022-09-14 09:48, Mathieu Othacehe wrote:

> Hello Nicolas,
>
>>  ...td-add-error-handling-for-robustness.patch | 242 ++++++++++++++++++
>>  .../patches/restartd-fix-compilation.patch    |  53 ++++
>
> Both patches also need to be added to the dist_patch_DATA variable of
> gnu/local.mk.
>
> Thanks,
>
> Mathieu
>
>
>
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a4c5189222..57de594bee 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -51,6 +51,7 @@ 
 ;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5455,6 +5456,59 @@  (define-public fail2ban
 mechanisms if you really want to protect services.")
     (license license:gpl2+)))

+(define-public restartd
+  (let* ((commit "7044125ac55056f2663536f7137170edf92ebd75")
+         ;; Version is 0.2.4 in the version file in the repo
+         ;; but not in github tags.
+         ;; It is released as 0.2.3-1.1 for other distributions.
+         ;; Probably because of the lack of activity upstream.
+         (revision "1"))
+    (package
+      (name "restartd")
+      (version (git-version "0.2.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ajraymond/restartd")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1m1np00b4zvvwx63gzysbi38i5vj1jsjvh2s0p9czl6dzyz582z0"))
+         (patches
+          (search-patches
+           "restartd-fix-compilation.patch"
+           "restartd-add-error-handling-for-robustness.patch"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:tests? #f ; no tests
+        #:make-flags
+        #~(list (string-append "CC=" #$(cc-for-target)))
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete  'configure)
+            (replace 'install
+              (lambda _
+                (install-file "restartd.conf" (string-append #$output "/etc"))
+                (install-file "restartd" (string-append #$output "/sbin"))
+                (install-file "restartd.8"
+                              (string-append #$output "/share/man/man8"))
+                (mkdir-p (string-append #$output "/share/man/fr/man8"))
+                (copy-file
+                 "restartd.fr.8"
+                 (string-append #$output "/share/man/fr/man8/restartd.8")))))))
+      (home-page "https://launchpad.net/debian/+source/restartd")
+      (synopsis "Daemon for restarting processes")
+      (description "This package provides a daemon for checking running and not
+running processes.  It reads the /proc directory every n seconds and does a
+POSIX regexp on the process names.  The daemon runs an user-provided script
+when it detects a program in the running processes, or an alternate script if
+it doesn't detect the program.  The daemon can only be called by the root
+user, but can use @code{sudo -u user} in the process called if needed.")
+      (license license:gpl2+))))
+
 (define-public rex
   (package
     (name "rex")
diff --git a/gnu/packages/patches/restartd-add-error-handling-for-robustness.patch b/gnu/packages/patches/restartd-add-error-handling-for-robustness.patch
new file mode 100644
index 0000000000..33f5f06555
--- /dev/null
+++ b/gnu/packages/patches/restartd-add-error-handling-for-robustness.patch
@@ -0,0 +1,242 @@ 
+From ec606eb15091ff8ffa672500413128c29814f8ad Mon Sep 17 00:00:00 2001
+From: Maxime Devos <maximedevos@telenet.be>, Yin Kangkai <yinkangkai@xiaomi.com>
+Date: Thu, 25 Aug 2022 14:29:25 +0200
+Subject: [PATCH] Add some error handling for robustness.
+
+This patch is a merge of two pull requests for the restartd project.
+
+Maxime Devos <maximedevos@telenet.be>
+https://github.com/ajraymond/restartd/pull/8
+
+This makes the code a little more robust. What if /var/run does not
+exist, or we do not have permission to open
+/var/run/restartd.pid (EPERM?) due to SELinux misconfiguration?
+
+Yin Kangkai <yinkangkai@xiaomi.com>
+https://github.com/ajraymond/restartd/pull/6
+
+This patch also avoids segmentation fault when run from non-root user.
+
+---
+ config.c   | 19 ++++++++++----
+ config.h   |  2 ++
+ restartd.c | 73 ++++++++++++++++++++++++++++++++++++++++++++++--------
+ 3 files changed, 79 insertions(+), 15 deletions(-)
+
+diff --git a/config.c b/config.c
+index f307b8a..94907e3 100644
+--- a/config.c
++++ b/config.c
+@@ -57,7 +57,11 @@ int read_config(void)
+     config_process_number = 0;
+
+     line1 = (char *) malloc(MAX_LINE_LENGTH);
++    if (!line1)
++      oom_failure();
+     line2 = (char *) malloc(MAX_LINE_LENGTH);
++    if (!line2)
++      oom_failure();
+
+     if ((config_fd = fopen(config_file, "rt")) == NULL) {
+         fprintf(stderr, "Error at opening config file: %s\n", config_file);
+@@ -155,11 +159,16 @@ void dump_config(void) {
+     int i;
+
+     for(i=0; i<config_process_number; i++) {
+-        printf("ID=%d\n  name=%s\n  regexp=%s\n  running=%s\n  not_running=%s\n", i,
+-            config_process[i].name,
+-            config_process[i].regexp,
+-            config_process[i].running,
+-            config_process[i].not_running);
++      if (printf("ID=%d\n  name=%s\n  regexp=%s\n  running=%s\n  not_running=%s\n", i,
++		 config_process[i].name,
++		 config_process[i].regexp,
++		 config_process[i].running,
++		 config_process[i].not_running) < 0) {
++	/* Maybe stdout points to a file and a file system quotum was exceeded? */
++	fprintf(stderr, "Failed to dump the configuration. Exiting.\n");
++	syslog(LOG_ERR, "Failed to dump the configuration. Exiting.");
++	exit(1);
++      }
+     }
+
+ }
+diff --git a/config.h b/config.h
+index fabaa2b..b5a134a 100644
+--- a/config.h
++++ b/config.h
+@@ -1,6 +1,7 @@
+ /* restartd - Process checker and/or restarter daemon
+  * Copyright (C) 2000-2002 Tibor Koleszar <oldw@debian.org>
+  * Copyright (C) 2006 Aurélien GÉRÔME <ag@roxor.cx>
++ * Copyright (C) 2022 Maxime Devos <maximedevos@telenet.be>
+  *
+  * This program is free software; you can redistribute it and/or
+  * modify it under the terms of the GNU General Public License
+@@ -43,5 +44,6 @@ typedef struct config_process_type {
+
+ int read_config(/* char *config_file */);
+ void dump_config(void);
++void oom_failure(void);
+
+ #endif /* RESTARTD_CONFIG_H */
+diff --git a/restartd.c b/restartd.c
+index 2aa720c..df0a6eb 100644
+--- a/restartd.c
++++ b/restartd.c
+@@ -1,6 +1,8 @@
+ /* restartd - Process checker and/or restarter daemon
+  * Copyright (C) 2000-2002 Tibor Koleszar <oldw@debian.org>
+  * Copyright (C) 2006 Aurélien GÉRÔME <ag@roxor.cx>
++ * Copyright (C) 2016 Yin Kangkai <yinkangkai@xiaomi.com>
++ * Copyright (C) 2022 Maxime Devos <maximedevos@telenet.be>
+  *
+  * This program is free software; you can redistribute it and/or
+  * modify it under the terms of the GNU General Public License
+@@ -52,6 +54,17 @@ void got_signal(int sig)
+     }
+ }
+
++/* Ignoring out-of-memory failures is risky on systems without virtual memory
++   where additionally at address 0 there is actually something important
++   mapped. Additionally, while often on Linux the OOM killer will kill processes
++   where an OOM happens, this is not always the case and there exist other systems
++   without an OOM killer (e.g. the Hurd). */
++void oom_failure()
++{
++  syslog(LOG_ERR, "Failed to allocate memory. Exiting.");
++  exit(1);
++}
++
+ int main(int argc, char *argv[])
+ {
+     DIR *procdir_id;
+@@ -75,15 +88,21 @@ int main(int argc, char *argv[])
+
+     /* Options */
+     config_file = strdup(DEFAULT_CONFIG);
++    if (!config_file)
++      oom_failure();
++
+     list_only = 0;
+
+     for(i = 0; i < argc; i++) {
+         if (!strcmp(argv[i], "-c") || !strcmp(argv[i], "--config")) {
+             config_file = strdup(argv[i + 1]);
++	    if (!config_file)
++	      oom_failure();
+         }
+         if (!strcmp(argv[i], "-v") || !strcmp(argv[i], "--version")) {
+             printf("restard %s - Copyright 2000-2002 Tibor Koleszar <oldw@debian.org>\n"
+-                   "                Copyright 2006 Aurélien GÉRÔME <ag@roxor.cx>\n",
++                   "                Copyright 2006 Aurélien GÉRÔME <ag@roxor.cx>\n"
++                   "                Copyright 2022 Maxime Devos <maximedevos@telenet.be>\n",
+                    VERSION);
+             exit(0);
+         }
+@@ -118,10 +137,13 @@ int main(int argc, char *argv[])
+                     "  -i <interval_sec>: the check interval in second\n"
+                     "  -l               : list configuration options\n"
+                     "  -h               : help\n\n", VERSION);
++	    exit(0);
+         }
+     }
+
+     config_process = malloc(sizeof(struct config_process_type) * 128);
++    if (!config_process)
++      oom_failure();
+
+     read_config();
+     if (list_only) {
+@@ -133,9 +155,17 @@ int main(int argc, char *argv[])
+            config_process_number);
+
+     procdir_dirent = malloc(sizeof(struct dirent));
++    if (!procdir_dirent)
++      oom_failure();
+     proc_cmdline_str = (char *) malloc(1024);
++    if (!proc_cmdline_str)
++      oom_failure();
+     proc_cmdline_name = (char *) malloc(1024);
++    if (!proc_cmdline_name)
++      oom_failure();
+     regc = malloc(1024);
++    if (!regc)
++      oom_failure();
+
+     /* Catch signals */
+     signal(SIGTERM, got_signal);
+@@ -187,8 +217,18 @@ int main(int argc, char *argv[])
+         }
+
+         out_proc = fopen("/var/run/restartd.pid", "wt");
+-        fprintf(out_proc, "%d", getpid());
+-        fclose(out_proc);
++	if (!out_proc) {
++	  syslog(LOG_ERR, "Failed to open /var/run/restartd.pid");
++	  return -1;
++	}
++        if (fprintf(out_proc, "%d", getpid()) < 0) {
++	  syslog(LOG_ERR, "Failed to write to /var/run/restartd.pid. Exiting.");
++	  return -1;
++	}
++        if (fclose(out_proc) < 0) { /* errors can happen when flushing the buffer */
++	  syslog(LOG_ERR, "Failed to write to /var/run/restartd.pid. Exiting.");
++	  return -1;
++	}
+
+         while(1) {
+             if ((procdir_id = opendir("/proc")) == NULL) {
+@@ -237,16 +277,23 @@ int main(int argc, char *argv[])
+            now = time(NULL);
+
+            out_proc = fopen("/var/run/restartd", "wt");
++	   if (!out_proc) {
++	     syslog(LOG_ERR, "Failed to open /var/run/restartd");
++	     return -1;
++	   }
+
+-           fprintf(out_proc, "%s\n", ctime(&now));
++           if (fprintf(out_proc, "%s\n", ctime(&now)) < 0) {
++	     syslog(LOG_ERR, "Failed to write to /var/run/restartd. Exiting.");
++	     return -1;
++	   }
+
+            for(i=0; i<config_process_number; i++) {
+                if (strlen(config_process[i].processes) > 0) {
+                    if (strlen(config_process[i].running) > 0) {
+                        strcpy(config_process[i].status, "running");
+-                       syslog(LOG_INFO, "%s is running, executing '%s'",
++                       /* syslog(LOG_INFO, "%s is running, executing '%s'",
+                               config_process[i].name,
+-                              config_process[i].running);
++                              config_process[i].running); */
+                        system(config_process[i].running);
+                     } else {
+                         strcpy(config_process[i].status, "running");
+@@ -267,12 +314,18 @@ int main(int argc, char *argv[])
+                     strcpy(config_process[i].status, "not running");
+                 }
+
+-                fprintf(out_proc, "%-12s %-12s      %s\n",
+-                        config_process[i].name, config_process[i].status,
+-                        config_process[i].processes);
++		if (fprintf(out_proc, "%-12s %-12s      %s\n",
++			    config_process[i].name, config_process[i].status,
++			    config_process[i].processes) < 0) {
++		  syslog(LOG_ERR, "Failed to write to /var/run/restartd. Exiting.");
++		  return -1;
++		}
+             }
+
+-            fclose(out_proc);
++	    if (fclose(out_proc) < 0) {
++	      syslog(LOG_ERR, "Failed to write to /var/run/restartd.pid. Exiting.");
++	      return -1;
++	    }
+
+             sleep(check_interval);
+         }
+--
+2.37.2
+
diff --git a/gnu/packages/patches/restartd-fix-compilation.patch b/gnu/packages/patches/restartd-fix-compilation.patch
new file mode 100644
index 0000000000..a380205675
--- /dev/null
+++ b/gnu/packages/patches/restartd-fix-compilation.patch
@@ -0,0 +1,53 @@ 
+From 84edc2042bb0a82e65bd4d165b706519886b4075 Mon Sep 17 00:00:00 2001
+From: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
+Date: Mon, 10 Aug 2020 19:39:30 +0100
+Subject: [PATCH] Fix build with gcc-10
+
+Bug: https://bugs.debian.org/957761
+Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
+---
+ config.h   | 12 ++++++------
+ restartd.c |  7 +++++++
+ 2 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git a/config.h b/config.h
+index fabaa2b..a79b28e 100644
+--- a/config.h
++++ b/config.h
+@@ -25,12 +25,12 @@
+
+ #define DEFAULT_CONFIG "/etc/restartd.conf"
+
+-int debug;
+-int config_process_number;
+-int check_interval;
+-int foreground;
+-struct config_process_type *config_process;
+-char *config_file;
++extern int debug;
++extern int config_process_number;
++extern int check_interval;
++extern int foreground;
++extern struct config_process_type *config_process;
++extern char *config_file;
+
+ typedef struct config_process_type {
+   char name[64];
+diff --git a/restartd.c b/restartd.c
+index 2aa720c..617b298 100644
+--- a/restartd.c
++++ b/restartd.c
+@@ -35,6 +35,13 @@
+
+ #include "config.h"
+
++int debug;
++int config_process_number;
++int check_interval;
++int foreground;
++struct config_process_type *config_process;
++char *config_file;
++
+ /* SIGTERM & SIGHUP handler */
+ void got_signal(int sig)
+ {