diff mbox series

[bug#57437] Add the wmamixer window maker applet package

Message ID 87a67qoji4.fsf@tsyesika.se
State Accepted
Headers show
Series [bug#57437] Add the wmamixer window maker applet package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jessica Tallon Aug. 26, 2022, 8:06 p.m. UTC

Comments

Ludovic Courtès Sept. 4, 2022, 9:18 p.m. UTC | #1
Hi,

Jessica Tallon <tsyesika@tsyesika.se> skribis:

>>From c3ce865bf0835a6d0771abad6d86e7ffec060e19 Mon Sep 17 00:00:00 2001
> Message-Id: <c3ce865bf0835a6d0771abad6d86e7ffec060e19.1661544356.git.tsyesika@tsyesika.se>
> From: Jessica Tallon <tsyesika@tsyesika.se>
> Date: Fri, 26 Aug 2022 21:34:05 +0200
> Subject: [PATCH] Add the wmamixer window maker applet package
>
> ---
>  gnu/packages/gnustep.scm | 37 +++++++++++++++++++++++++++++++++++++

I passed it through ‘guix style’, tweaked the commit log following our
conventions, and applied it.

Thank you!

Ludo’.
M Sept. 6, 2022, 11:12 a.m. UTC | #2
On 26-08-2022 22:06, Jessica Tallon wrote:
> +          ;; The make file doesn't support these phases.
> +          (delete 'configure)

The Makefile uses gcc, even when compiling natively. But when 
cross-compiling, it needs to use a cross-compiler.

You will need to replace 'gcc' by (cc-for-target):

(replace 'configure
   (lambda _
     (substitute "Makefile"
       ;; For cross-compilation.
       (("\\bgcc\\b") #$(cc-for-target))
       ;; Stripping is already handled by gnu-build-system.
       (("\\bstrip\\b") ":"))))

Greetings,
Maxime.
diff mbox series

Patch

From c3ce865bf0835a6d0771abad6d86e7ffec060e19 Mon Sep 17 00:00:00 2001
Message-Id: <c3ce865bf0835a6d0771abad6d86e7ffec060e19.1661544356.git.tsyesika@tsyesika.se>
From: Jessica Tallon <tsyesika@tsyesika.se>
Date: Fri, 26 Aug 2022 21:34:05 +0200
Subject: [PATCH] Add the wmamixer window maker applet package

---
 gnu/packages/gnustep.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index ba7060504c..5243fa8d66 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -36,6 +36,7 @@  (define-module (gnu packages gnustep)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages autotools)
@@ -335,3 +336,39 @@  (define-public wmfire
 symbols to represent the current monitor are \"burnt\" onscreen.  The flame
 colour can also be changed.")
     (license license:gpl2+)))
+
+(define-public wmamixer
+  (package
+    (name "wmamixer")
+    (version "1.0")
+    (source
+     (origin (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/gryf/wmamixer")
+                   (commit version)))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "04vv4kr4mj1nwri6zqgdg4yzbbmmng73qd4h0azliril75m7sldf"))))
+    (inputs (list libx11 libxpm libxext alsa-lib))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; The make file doesn't support these phases.
+          (delete 'configure)
+          (delete 'check)
+          (replace 'install
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (bin (string-append out "/bin")))
+                (install-file "wmamixer" bin)))))))
+    (synopsis "Window maker applet to display the current volume")
+    (description "wmamixer is an applet for window maker which displays the
+current volume level both numerically and visiaully with a volume bar.  It
+includes the ability to toggle through different outputs to show their
+respective volume level.")
+    (home-page "https://github.com/gryf/wmamixer")
+    (license license:gpl2+)))
+

base-commit: 80baa8f87aa69151dffe04fb432a37c91d4dd242
-- 
2.37.2