diff mbox series

[bug#61446] gnu: Add qbittorrent-nox.

Message ID 87a61jjwra.wl-hako@ultrarare.space
State New
Headers show
Series [bug#61446] gnu: Add qbittorrent-nox. | expand

Commit Message

Hilton Chain Feb. 12, 2023, 5:08 a.m. UTC
* gnu/packages/bittorrent.scm (qbittorrent-nox): New variable.
---
 gnu/packages/bittorrent.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)


base-commit: 4a6f64ab2afff761eb233e7ca6110d9e8acf8f32

Comments

Josselin Poiret May 17, 2023, 9:26 p.m. UTC | #1
Hi Hilton,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/bittorrent.scm (qbittorrent-nox): New variable.

LGTM, applied as d845202d357057b586ec2075a8b8ec492210c005.

Pro-tip: I guess because your mail domain has a strict DKIM policy, your
mail's subject being rewritten by debbugs causes it to fail, and so
mailman then rewrites the From: header to the generic mailing list
address.  This causes your patches to have the mailing list's address
when applying.  You can remedy this by adding
format.forceinbodyfrom=true to your git config, which will always add a
pristine From: in the body of the mail.

Best,
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index c3257cf2bf..ab4091009d 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -491,6 +491,23 @@  (define-public qbittorrent
 features.")
     (license l:gpl2+)))
 
+(define-public qbittorrent-nox
+  (let ((base qbittorrent))
+    (package
+      (inherit base)
+      (name "qbittorrent-nox")
+      (arguments
+       (substitute-keyword-arguments (package-arguments base)
+         ((#:configure-flags configure-flags)
+          #~(append #$configure-flags
+                    (list "--disable-gui")))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (delete 'wrap-qt)))))
+      (inputs
+       (modify-inputs (package-inputs base)
+         (delete "qtsvg-5"))))))
+
 (define-public deluge
   (package
     (name "deluge")