diff mbox series

[bug#63356] gnu: ftxui: Update to 4.0.0.

Message ID 87a5yf47sh.fsf@gmail.com
State New
Headers show
Series [bug#63356] gnu: ftxui: Update to 4.0.0. | expand

Commit Message

Artyom V. Poptsov May 8, 2023, 7:11 a.m. UTC
Hello,

this patch updates FTXUI[1] to 4.0.0 and fixes its build.
- avp

References:
1. https://github.com/ArthurSonzogni/FTXUI

Comments

宋文武 May 13, 2023, 9:57 a.m. UTC | #1
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

> Hello,
>
> this patch updates FTXUI[1] to 4.0.0 and fixes its build.
>

Hello, it was already updated to 4.0.0 by another patch.
But this patch's add 'benchmark' and remove the #:phases still apply, so
I did that.

Thank you!
Artyom V. Poptsov May 14, 2023, 8:11 p.m. UTC | #2
Hello!

> Hello, it was already updated to 4.0.0 by another patch.
> But this patch's add 'benchmark' and remove the #:phases still apply, so
> I did that.

Thanks, I'm glad you found my patch useful.

- avp
diff mbox series

Patch

From 492897d7e9a266fecafa31da2342e63b604364e6 Mon Sep 17 00:00:00 2001
Message-Id: <492897d7e9a266fecafa31da2342e63b604364e6.1683529548.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 8 May 2023 10:05:31 +0300
Subject: [PATCH] gnu: ftxui: Update to 4.0.0.

* gnu/packages/cpp.scm (ftxui): Update to 4.0.0.
  [native-inputs]: Add benchmark.
  [arguments]: Remove phase modifiers.
---
 gnu/packages/cpp.scm | 22 +++++-----------------
 1 file changed, 5 insertions(+), 17 deletions(-)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0337..242ea088bb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -67,6 +67,7 @@  (define-module (gnu packages cpp)
   #:use-module (gnu packages)
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages benchmark)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages c)
@@ -2433,7 +2434,7 @@  (define-public wdl
 (define-public ftxui
   (package
     (name "ftxui")
-    (version "3.0.0")
+    (version "4.0.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2441,27 +2442,14 @@  (define-public ftxui
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "10a4yw2h29kixxyhll6cvrwyscsvz9asxry857a9l8nqvbhs946s"))
+                "01h59ln8amsj6ymxmsxhmslld2yp003n82fg3mphgkrh6lf22h6y"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
-    (native-inputs (list googletest))
+    (native-inputs (list googletest benchmark))
     (arguments
      (list #:configure-flags
            #~(list "-DFTXUI_BUILD_TESTS:BOOL=ON"
-                   "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")
-           #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'unpack 'patch-cmake-tests
-                 (lambda _
-                   (substitute* "cmake/ftxui_test.cmake"
-                     (("NOT googletest_POPULATED")
-                      "FALSE"))
-                   ;; Disable benchmarks for a while as they require bundled Google
-                   ;; benchmark and when the 'googlebenchmark' is unbundled, there's
-                   ;; a CMake configuration error.
-                   (substitute* "cmake/ftxui_benchmark.cmake"
-                     (("NOT WIN32")
-                      "FALSE")))) )))
+                   "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")))
     (home-page "https://github.com/ArthurSonzogni/FTXUI")
     (synopsis "C++ Functional Terminal User Interface")
     (description

base-commit: b7e77446261fdc8dab360d7835a5dec919f6a79f
-- 
2.34.1