diff mbox series

bug#67644: [PATCH] gnu: pypy: Update to 7.3.13.

Message ID 87a5qctplh.fsf@gnu.org
State New
Headers show
Series bug#67644: [PATCH] gnu: pypy: Update to 7.3.13. | expand

Commit Message

Ludovic Courtès Dec. 14, 2023, 9:56 p.m. UTC
Hi,

Greg Hogan <code@greghogan.com> skribis:

> The validate-runpath error was previously reported in #57653.
>
> Version update fixes the existing build errors.
>
> * gnu/packages/python.scm (pypy3): Update to 7.3.13.
> [source]: Update origin URI.
> [arguments]<#:validate-runpath>: Disable check.
> [arguments]<#:phases>: Update directory paths.
>
> Change-Id: Ic6ab7dd77e30fa85d6fa5f000f9aa2528951b81e

Applied after adding a comment to justify #:validate-runpath? #f (which
should be used if and only if we have a very good reason to turn it
off—it almost never gives false positives, but this case is an
exception).

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/pypy.scm b/gnu/packages/pypy.scm
index 59c368417e..a39621b5ad 100644
--- a/gnu/packages/pypy.scm
+++ b/gnu/packages/pypy.scm
@@ -54,7 +54,11 @@  (define-public pypy
     (arguments
      (list
       #:tests? #f                      ;FIXME: 43 out of 364 tests are failing
+
+      ;; XXX: ELF file 'pypy.debug' makes 'validate-needed-in-runpath' throw:
+      ;; <https://issues.guix.gnu.org/57653>.
       #:validate-runpath? #f
+
       #:modules '((ice-9 ftw) (ice-9 match)
                   (guix build utils) (guix build gnu-build-system))
       #:disallowed-references (list nss-certs)