diff mbox series

[bug#69043,v2] gnu: go-github-com-charmbracelet-bubbletea: Remove examples.

Message ID 87a5o79bpp.fsf@troyfigiel.com
State New
Headers show
Series [bug#69043,v2] gnu: go-github-com-charmbracelet-bubbletea: Remove examples. | expand

Commit Message

Troy Figiel Feb. 11, 2024, 12:24 a.m. UTC
* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): Remove
examples and tutorials.
[arguments]<#:phases>: Add remove-examples phase.
---
 gnu/packages/golang.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)


base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..734db8ca30 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10446,7 +10446,14 @@  (define-public go-github-com-charmbracelet-bubbletea
          "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/charmbracelet/bubbletea"))
+     (list
+      #:import-path "github.com/charmbracelet/bubbletea"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-examples
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (with-directory-excursion (string-append "src/" import-path)
+                         (for-each delete-file-recursively
+                                   '("examples" "tutorials"))))))))
     (propagated-inputs
      `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
        ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)