diff mbox series

[bug#69244] gnu: go-golang-org-x-net-html: Add missing input.

Message ID 87a5nzat2b.fsf@troyfigiel.com
State New
Headers show
Series [bug#69244] gnu: go-golang-org-x-net-html: Add missing input. | expand

Commit Message

Troy Figiel Feb. 17, 2024, 5:38 p.m. UTC
* gnu/packages/golang-build.scm (go-golang-org-x-net-html): Add missing input.
[propagated-inputs]: Add go-golang-org-x-text.
---
 gnu/packages/golang-build.scm | 2 ++
 1 file changed, 2 insertions(+)


base-commit: 91d80460296e2d5a01704d0f34fb966a45a165ae

Comments

Sharlatan Hellseher Feb. 18, 2024, 10:08 p.m. UTC | #1
Hi Troy,

I've started review process for all Golang related patches sent.

Did you check the go.mod for the commit of go-golang-org-x-net package?
It looks like it need 2 more modules

<https://cs.opensource.google/go/x/net/+/8e0e7d8d38f2b6d21d742845570dde2902d06a1d:go.mod>
--8<---------------cut here---------------start------------->8---
module golang.org/x/net

go 1.17

require (
    golang.org/x/sys v0.4.0
    golang.org/x/term v0.4.0
    golang.org/x/text v0.6.0
)
--8<---------------cut here---------------end--------------->8---

Due to large amount of impact for any packages in golang-build, I would
place it in go-team branch (not existing yet).

May, please, double check if we need golang.org/x/sys and
golang.org/x/term and send v2 if so.

--
Oleg
Troy Figiel Feb. 18, 2024, 10:47 p.m. UTC | #2
Hi Oleg,

On 2024-02-18 23:08, Sharlatan Hellseher wrote> Did you check the go.mod
for the commit of go-golang-org-x-net package?
> It looks like it need 2 more modules
> 

The entire module (golang.org/x/net) does need those two Go packages,
but the golang.org/x/net/html Go package does not, i.e. the inputs as I
sent them are correct.

This is a result of how Guix has packaged Go in the past, with a Guix
package per Go package, not per Go module. This means we cannot reliably
use the go.mod file to determine dependencies, as there might be a bunch
that we do not need.

For future Guix packages, I think it will be easier to follow the Go
module structure instead, but that is a topic for the mailing list :-)

> Due to large amount of impact for any packages in golang-build, I would
> place it in go-team branch (not existing yet).
> 

With "guix refresh -l go-golang-org-x-net-html" I only see 2 dependents
(emacs-ghq rebuilds both). I am not sure I understand what you mean.

In general though, feel free to apply these missing inputs, fixes, etc.
whenever is convenient. I am locally working with a separate branch,
which already uses the "/..." fix (for both the build and check phases)
and I regularly rebase this branch on master. Sending updated patches is
no issue.

Best wishes,

Troy
Sharlatan Hellseher Feb. 20, 2024, 12:04 a.m. UTC | #3
Hi,

Pushed as d234999cac6d6f16ce121ed2ead28adc0d41b5ed to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 8b7dca46a6..04267845a5 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -252,6 +253,7 @@  (define-public go-golang-org-x-net-html
     (arguments
      '(#:import-path "golang.org/x/net/html"
        #:unpack-path "golang.org/x/net"))
+    (propagated-inputs (list go-golang-org-x-text))
     (home-page "https://godoc.org/golang.org/x/net/html")
     (synopsis "HTML5-compliant tokenizer and parser")
     (description