diff mbox series

[bug#71460] Fixing commit message

Message ID 87a5js95uz.fsf@thanosapollo.org
State New
Headers show
Series [bug#71460] Fixing commit message | expand

Commit Message

Thanos Apollo June 10, 2024, 3:26 p.m. UTC
Same patch, this time with a generated =Change-Id: ***=. Still learning
how to properly format patches for Guix.

Comments

Nicolas Goaziou June 10, 2024, 4:32 p.m. UTC | #1
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

> Same patch, this time with a generated =Change-Id: ***=. Still learning
> how to properly format patches for Guix.

Thank you (for the package, too!).

> Subject: [PATCH] gnu: emacs-yeetube: Update to 2.1.6
>
> * gnu/packages/emacs-xyz.scm (emacs-yeetube): Update to 2.1.6.

You need to add that you removed wget dependency:

  [arguments]<#:phases>: No longer replace (executable-find "wget") in
  the code base.
  [inputs]: Remove WGET.

> Change-Id: I6aee95029e829170a98d8fb7447bf0fd39ed6176
> ---
>  gnu/packages/emacs-xyz.scm | 13 +++++--------
>  1 file changed, 5 insertions(+), 8 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 2a943f5846..1d0519aa88 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -29074,10 +29074,10 @@ (define-public emacs-ytel-show
>        (license license:gpl3+))))
>  
>  (define-public emacs-yeetube
> -  (let ((commit "c74e4e77156297624d278a05bdd19c016a91ff9b")) ;version bump
> +  (let ((commit "c9721a295f4fd30a44e94b3424151fa8a14d22ae"))

Why are you removing the comment? It is used to indicate that upstream
does not tag commits, but this commit matches the version bump anyway.

Otherwise, LGTM.

Regards,
diff mbox series

Patch

From da0f8661c6524bb2f75631f3f79a8d885c5bce1d Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Mon, 10 Jun 2024 18:14:30 +0300
Subject: [PATCH] gnu: emacs-yeetube: Update to 2.1.6

* gnu/packages/emacs-xyz.scm (emacs-yeetube): Update to 2.1.6.

Change-Id: I6aee95029e829170a98d8fb7447bf0fd39ed6176
---
 gnu/packages/emacs-xyz.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a943f5846..1d0519aa88 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29074,10 +29074,10 @@  (define-public emacs-ytel-show
       (license license:gpl3+))))
 
 (define-public emacs-yeetube
-  (let ((commit "c74e4e77156297624d278a05bdd19c016a91ff9b")) ;version bump
+  (let ((commit "c9721a295f4fd30a44e94b3424151fa8a14d22ae"))
     (package
       (name "emacs-yeetube")
-      (version "2.1.4")
+      (version "2.1.6")
       (source
        (origin
          (method git-fetch)
@@ -29086,7 +29086,7 @@  (define-public emacs-yeetube
                (commit commit)))
          (sha256
           (base32
-           "1gpfm41d4wzk1i0hnmfn81xv05ida9ljibar7ji4d7nisjbd4vp9"))
+           "0lrcs0n30h800sm6py4av44a3fcfgasmj223mnl76q34syyrgz6k"))
          (file-name (git-file-name name version))))
       (build-system emacs-build-system)
       (arguments
@@ -29102,15 +29102,12 @@  (define-public emacs-yeetube
                   (("\\(executable-find \"torsocks\"\\)")
                    (format #f "~s"
                            (search-input-file inputs "/bin/torsocks")))
-                  (("\\(executable-find \"wget\"\\)")
-                   (format #f "~s"
-                           (search-input-file inputs "/bin/wget")))
                   (("\\(executable-find \"yt-dlp\"\\)")
                    (format #f "~s"
                            (search-input-file inputs "/bin/yt-dlp")))))))))
-      (inputs (list mpv torsocks wget yt-dlp))
+      (inputs (list mpv torsocks yt-dlp))
       (propagated-inputs (list emacs-compat))
-      (home-page "https://thanosapollo.com/blog/yeetube/")
+      (home-page "https://thanosapollo.org/projects/yeetube/")
       (synopsis "Youtube and Invidious front-end for Emacs")
       (description
        "This package offers an Emacs interface that allows you to search YouTube
-- 
2.45.1